EssentialsX replacing default /give and /tp commands

I’m not sure if this is the right place to ask this, but this is the only place I can go without making an account somewhere else (I’d rather only do that when I know that I’ll frequently be there).

My problem is with the EssentialsX Spigot plugin.
It includes a replacement for the default /give and /tp commands, and those don’t allow me to tab-complete the command, for example when I want to give myself something, I usually just type /give, press space, type the first letter of my username and then press tab, which will auto complete it. But the EssentialsX replacement doesn’t allow me to do that.

I’ve tried disabling the give and tp commands in the EssentialsX config file, but that just disables the entire command, including the default one, so I’m looking for a way to completely remove the command from EssentialsX, so that I can use the default one.

Any help is appreciated, and you may also let me know if this just isn’t the right place for this question and I’ll go look elsewhere.

I have absolutely NO clue if this will work and it is beyond a shot in the dark. Can you take away your permission to use and give permission to do the vanilla commands? Just a complete shot in the dark.

Then there is of course doing “/mi tab:tp” which turns into /minecraft:tp

The /minecraft:tp works fine, thanks for that.

I’m still trying to figure out how it works with the permissions, so I wont be messing around with that yet.
I just don’t understand what the point of replacing the default commands with worse ones is.
I’ve found that the normal essentials (without the x) plugin works somewhat better, but it can only autocomplete player names.

Ok, for future reference and for others with the same or similar problem: I fixed it by opening the EssentialsX jar file with 7-zip and editing plugin.yml. I removed the entries from the commands I didn’t want and that worked for me.