Error When Starting Server

I have looked through many forums and found some troubleshooting tips, but after following what I could I am still encountering the same error. When trying to start my server I am seeing the following in the error logs. I know I ran out of space, but I deleted a number of old restore points and archive and have over 50% available now. I have also removed jar files and redownloaded the profile in order to recreate them.
Any help would be appreciated.
---- Minecraft Crash Report ----
// Oh - I know what I did wrong!

Time: 5/30/21 4:26 PM
Description: Exception in server tick loop

java.lang.NullPointerException: Exception in server tick loop
at acy.f(SourceFile:121)
at zf.y(SourceFile:95)
at zf.(SourceFile:22)
at zg.d(SourceFile:169)
at net.minecraft.server.MinecraftServer.w(SourceFile:645)
at net.minecraft.server.MinecraftServer.a(SourceFile:257)

A detailed walkthrough of the error, its code path and all known details is as follows:

– System Details –
Minecraft Version: 1.16.5
Minecraft Version ID: 1.16.5
Operating System: Linux (amd64) version 4.9.0-15-amd64
Java Version: 1.8.0_292, Oracle Corporation
Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 5728186536 bytes (5462 MB) / 5987893248 bytes (5710 MB) up to 7635730432 bytes (7282 MB)
CPUs: 4
JVM Flags: 2 total; -Xmx8192M -Xms4096M
Data Packs: vanilla, file/coordinates hud, file/durability ping, file/track raw statistics,
file/track statistics, file/back, file/classic fishing loot, file/homes, file/nether po
rtal coords, file/timber, file/tpa
Is Modded: Unknown (can’t tell)
Type: Dedicated Server (map_server.txt)