Downgrade Webui


#1

WebUI git commit: 23f10ac is spotty on if all server load, backups and archives are not displayed, I have to reload browser and log into WebUI to within a few seconds click on on the start button to even get my servers to start back up after I stop spigot server in game. Since the stop button will not work. Can’t import a server also can not add, suspend or start cronjobs. I have removed dynmap to see if issue goes away, no change. My mineOS.logs don’t seem to reveal any answer on how to fix to me. Most of these feature worked before I upgrade WebUI to the this version.


#2

If you think it’s connected to a commit, you can definitely roll back the commit.

Keep in mind, MineOS doesn’t really change anymore…not much at all. But provided that the npm dependencies do (because they presumably are being improved/secured), the biggest potential issue there is incompatibilities among node modules itself (the modules I don’t maintain).

This behavior, however, is something I’ve seen when there’s one or more servers that do not respond expectedly to the Minecraft server ping.

cd /usr/games/minecraft
git checkout xxxxxxx
npm install
supervisorctl restart mineos

#3

well I updated WebUI and I slowly the features stopped working. I first thought it was a corrupt partition so I tried to repair it and couldn’t so I started over with fresh install. imported a few servers updated WebUI and lost control of WebUI, no one had answer on how to fix, I did another fresh install of MineOS and this time I got server fully running before I updated WebUI and when I updated Webui lost control of WebUI again. been near 2 weeks with this issue and you guys can’t seem to give advice on how to fix.


#4

If you can provide a way I can reproduce the issue, I can address and fix the issue.

In the meantime, all we have is a single case of newer commits causing you issues, and hundreds upon hundreds of other cases where it works.

If you want to know how to fix this, start with only one server, on the latest commit. Test that the server and webui works.

Then, add one more. Test again.

You have nine servers. If even only one is causing problems, 8 will suffer. However, how am I to know which is doing it? We’d need to do it systematically.

Clarification: Adding a server means it’s not in /var/games/minecraft/ anywhere–so put it in your home directory. I think the easiest way to do this is to make an archive of ALL your servers. Then, move all your latest archives to your /home directory. Finally, one by one, copy/move them to /var/games/minecraft/import and import them.


#5

would be nice to try that but I am not able to create archives, backups and do anything, my archives range from a few months old and a year, and it took hours to get the maps and plugins updated so they are current.
Is there a way to run archives via command line


#6
cd /usr/games/minecraft
chmod +x mineos_console.js
./mineos_console.js -s [servername] [action]
./mineos_console.js -s MiniGames stop
./mineos_console.js -s MiniGames kill
./mineos_console.js -s MiniGames archive
./mineos_console.js -s MiniGames backup

#7

the first two servers archives went great third one gave me an error after about 5 mins
[Survival] Error executing “archive” because server condition not met: 2

Now I get error all the time as soon as I execute the archive command. Even the servers that Successfully executed archive. I was thinking my issues was with two of my servers Survival and Vanilla. I will reboot server later when players are off and see if I can get the rest of the archives.

I got the archives to complete, not sure if this fixed that issues, but I used your commands to stop and start all the servers one by one. I few of them wouldn’t stop at first not they stop and start normal. AFter I made all the archives I moved one server to my PC via WinSCP and then when I try to upload it to the import folder I get an error “Incoming packet was garbled on decryption”


#8

Well server crashed last night had no choice but to re-install everything, so far everything works great but one of my servers is giving me an issue on getting it back online. My guess that was the one which was causing the issue. My issue now is it didn’t delete all the folders when I tried to remove the server and start over. Is there a trick on how to clean up the folders and files that were left behind?

Update:
I got the old server removed I uploaded the root files to the server and then it allowed me to delete it again, now I have this issue;
{“command”:“start”,“uuid”:“151ad310-d704-11e7-ba93-730057c6863a”,“time_initiated”:1512179819201,“success”:false,“err”:“Cannot start server without a designated jar/phar.”,“time_resolved”:1512179819315,“level”:“error”,“message”:"[Survival] command “start” errored out:",“timestamp”:“2017-12-02T01:56:59.316Z”}