Commands being sent to wrong server


#1

I’m having a problem with MineOS and I’m not sure where to start troubleshooting. I have two servers called SuperCraft and SuperCraft_2 … when I’m in the WebUI and I send the restart command to the SuperCraft server, the SuperCraft_2 server shuts down. I can go to it in the WebUI and bring it back up without any problems.

I feel like there’s something that got mixed up somewhere and the WebUI thinks that the SuperCraft_2 processes are actually the SuperCraft processes. I tried to dig into the code a bit, but I couldn’t find any where to start troubleshooting the issue. Any advice on where I should be looking?


#2

This is a weird bug that pops up occationally when two servers have names that have too much in common. If I remember right @hexparrot have tried to look into it after I reported the same error, but was unable to reproduce it.

I have the same problem with two servers named “Frodo” and “FrodosPocket”, where one is a vanilla, and the other is a Pocketmine.


#3

Ahh, I actually saw your post when I was searching for mine, but it looked like it was an older post. Do we know the mechanics of how it searches for which pid to kill/restart? I wonder if it’s done via a Grep and it’s just returning the first result.


#4

I am not quite sure, but I somwhat expect that the error lies in the handling of the screens containing the different servers. This is because even though I issue the stop command through the log-command input it is somewhat random which one of the two that stops. That input window should be a command directline into the active window, and works perfectly for all other commands.

As I said , it is a weird error…

edit: it more often than not stops the right server thoug, writing “stop” in the server command console below the logs, but occationally it stops the other server in stead…


#5

Hmm, for what it’s worth the behavior on mine seems pretty consistent … but I’ve only run into this today, so… :slight_smile: