Can't use Bungeecord anymore?


#1

I use to run all my servers on Ubutntu, but ever since I swtiched to mineOS, everything has been better, except for the fact the BUNGEECORD DOES NOT WORK! I followed the steps of making a profile for it (downloading the jar) then making an unconventional minecraft server and launching after selecting heap size (-xmx 512M -xms512M) profile and jar. But when I click the start button, it will start for a moment, then stop on the first time after making the server, but then after it won’t even start, as if I never pressed the button. According to FileZilla, there aren’t even any files except for server.properties, Bungeecord-1152.jar, server.config, and a null file. The normal things aren’t being built, and I want to get back to using bungeecord again.


#2

Hi
Just tested with the latest bungeecord release (http://ci.md-5.net/job/BungeeCord/lastSuccessfulBuild/artifact/bootstrap/target/BungeeCord.jar). Works just fine for me.

To be able to help you further we would need to see some logs. In your case this means this log:

/var/log/mineos.log

Please use pastebin or an equivalent service to make your log available.


#3

Excuse my dumb, don’t you need to build a mc server, get it running first then add the bungeecord jar to it?


#4

Not when I tested it. You define all connections to servers in a config file. To generate a config file you neef to run bungee first.


#5

Worked just fine for me.

  1. Created unconventional server
  2. Downloaded " BungeeCord #1152 (stable)"
  3. Switched profile to “BungeeCord-1152”
  4. Switched jar to “BungeeCord-1152.jar”
  5. Hit start

Changes I didn’t make: “(-xmx 512M -xms512M)”. What was the actual values you filled into the java settings, perhaps you filled in more than just the numbers (don’t put in letters, and you shouldn’t put xmx/xms into other fields)?

That said, when I did fill in values, in my case “512” & “512”, it still started up.


#6

The PC I was using is unavailable atm, but in a VM I was able to make a Bungeecord, so I guess it was just the PC, but I’m still wondering what would be wrong with it, it runs windows vista find, and in MineOS it can run every OTHER type of server.


#7

My best guesses are that either a) there were non-numbers in the XMX/XMS values (any alphanumerics are bad), or b) the server just didn’t have the 512 as free, unused and available ram, so Java was erroring out.


#8

I didn’t see your other comment, but no, I was just putting the XMX/XMS for the post, in the fields in the web-ui, its just 512 512. I also tried 1024 512 (1024 being XMX, 512 XMS) but it didn’t work either. I think I’m just going to have a computer completely for bungeecord to fix this problem, but I would like to have only 2 computer to run the network.


#9

@Docter_Redstone:
So far we have only given you generic help. We have also tested Bungeecord on our own MineOS installations to confirm that it works. It does.

Without access to your logs we cannot help any further. Since Bungecord do not start up, and you say that the bungeecord directory stays empty other than the files generated by MineOS and the bungeecord jar, the only log available to us that we need is mineos.log. It is located at this path in your MineOS machine:

/var/log/mineos.log

Please supply us with that, and we can see what we can do to help.

Other options may be to give one of us access to your WebUI and SSH so that we could help you researching this fault. This of course is dependant on your MineOS machine being available through internet.


#10

Also worked for me with 512 x 512 on the heapsize.

Server updated itself and is listening however, I do not have a client so I can not say if laggy or glitchy it is, logs say very stable though.

Perhaps a bad d/l on your side?

It is as iMelsom says,

EDIT: On another note, wan’t bungeecord made obsolete and replaced by spigot? Sorry I just did not know enough about these kins of servers.

Thanks!


#11

BungeeCord was made to link multiple Spigot servers together, but would work with any other Minecraft server.


For me, WaterFall is my BungeeCord replacement, and Paper is my Spigot replacement.


#12

Thanks for the infoo JayMontana36.

Just goes to show how much I don’t know, never heard of Paper or Waterfall, or what one would need them for.

Just how many mc servers do you need? Is a ‘Server Farm’ required? (Just joking).

tNt


#13

Well there are a few reasons why one would want something like this, for example instead of having one server for multiple gamemodes/purposes (such as Creative, Survival, and Factions) with mixed chat, multiple worlds, and etc which would require extra plugins to prevent exploiting creative to get free items in the others, extra plugins to separate chat, extra plugins to disable plugins in certain worlds (last I heard of that plugin it no longer worked once 1.8 came out but I haven’t kept up to date on that) and so many more complications being that protection plugins can “conflict” with each other (an example of that being someone using the factions plugin to claim someone else’s plot in creative, causing the owner of the plot to not be able to build, and the person who claimed the plot still won’t be able to build). So it would indeed be so much easier to just have separate servers combined with WaterFall/BungeeCord, or do things the way it was before BungeeCord (which is to just have the servers separated with different IPs and/or ports).


#14

ROTFL! Crosseyed smoking brain.


#15

Here’s var\logs\mineos.log
http://pastebin.com/FsMrnVgC


#16

First:
I can see that you keep logging in with root:
“[WEBUI] root connected from ***.***.***.***”

MineOS is not made to be run as root, but with normal users. In the default Turnkey installation (The ISO) this is MC. Logging in as root will give problems with making and starting servers, and servers made as root will seldom behave properly.

I think this is the cause of your problem.
Sign in with the MC user and try again :slight_smile:

Second:
You have a java warning:
{“level”:“error”,“message”:“stderr: *** WARNING *** You are not using
Java 7 or above. Although this will work, it is highly discouraged due
to the security issues present.”,“timestamp”:“2016-05-13T06:51:36.477Z”}


#17

First blush I advise to update your MineOS.

Second blush, like iMelsom says, lol.

Regards,

tNt


#18

Logging into the web-ui with MC seemed to make things worse, now I don’t see any jars after downloading profiles, but I did notice that logging in with mc is a lot easier on my browsers memory for some reason, making it faster.


#19

the failure to provide profiles is possibly due to them being downloaded while you where logged in as root.

Try to download profiles again as the mc user.
Then try to create a new server as MC and see if the jars are correctly copied and shows up.


#20

You can’t see root-created servers with a non-root user. Just like I wouldn’t be able to see mc servers from the user will. You can correct this by changing permissions of your root owned servers:

chown -R mc:mc /var/games/minecraft/{servers,archive,backup}/*

Then, upon logging in with mc, you’ll see all the newly mc owned servers.