Can't start server throws Error start failed 23


#1

I’m trying to setup a minecraft server on my FreeNAS 11 using the mineos plugin.
For some probably really obvious reason I can’t start a minecraft server and just displays an error: start failed 23
I updated java and mineos but I am now stuck and can’t find anything that helps me.
Can somebody help me or has had a similar problem?

mineos.log:
{"command":"start","uuid":"73afe110-b402-11e7-9a29-9d33491fa80b","time_initiated":1508330828193,"success":false,"err":23,"time_resolved":1508330828483,"level":"error","message":"[test] command \"start\" errored out:","timestamp":"2017-10-18T12:47:08.484Z"}


#2

What Minecraft server are you trying to start? Do other profiles work?


#3

I’m trying to start 1.12.2 but none of the other versions are working either (showing the same error).
If i try to start the server.jar manually it seems to be working fine.
So i’m guessing it’s a problem with starting the server.jar from the mineos gui.


#4

Just to confirm, can you provide the mineos.log or at least say here what version of the webui you’re on? The commit can be found in the webui here.

image

Can you return to me the results of the following command from your minecraft script directory?

root@mineos games/minecraft# ./mineos_console.js -s SERVERNAMEHERE get_start_args
[ffff] Successfully executed "get_start_args"
[ '-dmS',
  'mc-ffff',
  '/usr/bin/java',
  '-server',
  '-Xmx512M',
  '-Xms512M',
  '-jar',
  'minecraft_server.1.12.2.jar',
  'nogui' ]

When you started the server manually, what user did you use?


#5

I’m running version d529e70 of the webui and i use the user mcserver to login and user the webui.
That’s the default user that is configured in the FreeNAS mineos plugin as far as i know.

To start the minecraft server manually over the shell i used the root user (just to see if it runs in the first place).

Output of the command:
[ ‘-dmS’,
‘mc-test’,
‘/usr/local/bin/java’,
‘-server’,
‘-Xmx1024M’,
‘-Xms1024M’,
‘-jar’,
‘minecraft_server.1.12.2.jar’,
‘nogui’ ]

I had to change permissions to mineos_console.js to do anything for some reason it was set to rw r r. Which leads me to believe that something is off with the permissions.


#6

By running the Minecraft server as root, the server will create files that are owned and modifiable only by root. Thus, 100% of attempts since then with mcserver are expected to fail.

There might be an issue here keeping the server from running (initially), but as of right now, the likeliest culprit of “error 23” is this.

Also, can you confirm /usr/local/bin/java is the version of Java you’re expecting?

The webui doesn’t actually use any of the permissions, e.g., rwx–this is the case when the app invokes nodejs directly with the file as an argument, rather than relying on the #!/....../nodejs line at the top of the file. I believe that this permission is not causing this issue.


#7

To be honest i gave up using the FreeNAS Plugin and tried again with a new Jail and setup everything manually.
There might be something wrong with the Plugin or more probable I somehow broke it.

I managed to start the server but selecting a runnable jar seems a bit buggy. Sometimes i can select it, sometimes not and sometimes if i select a jar, it just disappers. Might be a known issue i did not get around to google it.

Thx for your time