Cant start MineOS 1.16.5 forge server (as well as any forge server)

Recently I did the MineOS unofficial update thing, and though I now have the forge install options, I can not start the Forge servers. The vanilla works fine. I can start with the forge installer, but when I try to start it with the jar file, it wont start up. (I am trying to start the server with the Better Minecraft mod)
Ask me if you need any more information.

The installer works fine, but the server keeps of failing to start

Can you clarify what you mean here? Forge options have been available for ages, so no recent update to the webui should have impacted that.

How old is your installation? Has forge ever worked? What distro are you using? What version of Java are you using?

According to this page: cannot access class · Issue #832 · itzg/docker-minecraft-server · GitHub

Yes, most Forge things require Java 8. There’s a warning at he start that mentions compatibility issues.

MineOS now ships with Java 16 to support 1.17, but there’s a cutoff of how far backward compatibility reaches, and Forge might not be happy with Java 16.

Corroborated here, too:

Minecraft 1.16.5 is known to have issues with java 16, I recommend that you go and download Java 15 at

The unoffical update I did was in the freenas shell and I put in these commands:
fetch iocage fetch -P mineos.json -n mineos-test dhcp=1

Before i did it, i didnt have any access to the forge jar installers or whatever.

Forge did work before, but it did break which led me to doing that unofficial update

I’m sorry, but I’m still not sure what you mean by unofficial update, can you link me?

At the bottom of this page, I put in that code into the shell which downloaded mineos for me and let me see the forge profiles, but not use them.

also im using freenas and I dont know which and how to use any of those downloads for freenas

I’ve tried multiple reinstallations but none have worked yet, I can’t use forge profiles