Can't Start 1.19 Forge Server

I have tried this a few ways and settled eventually on building the server locally, then importing it to mineos. I’ve had success with this on other versions in the past. The server runs just fine, mods and all, locally. I import it through the web ui and get it all set up there. Click start, get the “Up…Down” response. No logs generated. Using the 1.19-latest forge profile and have the 1.19 forge installer(only option) selected for the runnable .jar. I have checked that Java 17 is installed on the server I’m using. The server has base mineos Turnkey installed. Nothing special. Any ideas why I can’t get this to start or even throw a log?

grab the required forge you need and ftp it into the server directory. you said you tested the server locally so just ftp over that forge jar that you used locally.

Locally there is no .jar in the local server directory. I installed it from the installer.jar to a specific directory. That same installer.jar is in the mineos server directory. I’m assuming I need the universal.jar but can’t find it anywhere on its own. I always thought that was created in the process.

yep it should be when you run the installer, said you tested the server locally so you would of need a uni jar for that. ftp that on over and use it

what i mean is if its not working on mineos the installer that is then just ftp that one over and use it

Again, there is NO universal .jar or any .jar for that matter on the local instance.
However, I did find that buried in the mineos server directory at /libraries/net/minecraftforge/forge/1.19-41.0.100 the universal is there. I copied it out and it does now show in the UI, but I still get “Up…down” and no logs

(post deleted by author)

so use the jar that you used to run the server again locally, you cannot test and run a server without a working forge jar so ftp that one over if mineos is giving you problems

I will repeat myself:
There isn’t a .jar in the local directory. When testing it locally I could run from the .bat or on the linux machine, .sh. The only .jar I have locally is the installer .jar which I already have on the server. That clearly does not work.
I did find a universal .jar underneath the files created on the mineos server. I put it in place, selected it within the UI, and STILL do not get logs or any results.

(post deleted by author)

you may want to say this from the get go then because it took us this long to get here, i cannot even be bothered at this point if you are going to omit something crucial like this then that does not really help anyone else either.

The assumption was up until now that you could not get the forge installer to work because of how you worded the post. Hence the following statement would lead most ppl to believe your issue is the forge installer not working.

now that you have a mentioned you do have a uni jar then your options are,

  • using the wrong java
  • using bad launch params

these two come to mind idk cbf at this point we are not mind readers btw. just define your target jar in the server.conf or what ever one it is.

Sorry not trying to sound abrasive at all but if you cannot really relay your issue in a concise manner then ideally those people that are trying to help you may not really understand you properly, i mean there is inconsistency to your thread.

Your opening posts makes your situation sounds like you are having trouble with the forge installer jar and then the subsequent posts after you are saying there is no universal jar as result which is the jar you need to run the server which totally backs up that line of thinking to someone external.

After advise based of the parameters up until that point in the timeline was given you then mention that there is a universal.jar now but it won’t work.

All this does is confuse someone else who is trying to think through your issue and what could be causing the problem because it changes the whole dynamic. if you are confused so is everyone else and we are just as confused as you allow us to be so you need to be clear when asking for help.


Replace versions with your version.

As ElPres mentioned that is one method obtainable to you that will achieve the same results. Really what the discrepancy is that for some reason your webui is not showing the java binary for what ever reason, you may just have to restart the process or even the server completely for it to appear in the drop down menu.

Although essentially the webui front end does not even need to show runable jars to work because you can just define one at
/var/games/minecraft/servers/ and it will work and run a server. Further there is a nuance to the webui in that its just a front end that is reading information in various configs etc so essentially as long as you have the required stuff setup properly and where it matters you can run the server and it will run.

eg i don’t even bother selecting anything in the drop downs and just run my server each time i need to start it as illustrated by the following image. Basically the drop downs are optional but not required.

For example this is what the drop down is referencing and it selects a target jar that is set in the file.
server.config which is inside any mc server you make. This can be generated from user input via the webui or you can just fill it out manually as its a plan cfg file.

java_tweaks=“-d64 -server -noverify -XX:+UseG1GC -XX:+ParallelRefProcEnabled -XX:MaxGCPauseMillis=20 -XX:+UnlockExperimentalVMOptions -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -XX:G1NewSizePercent=30 -XX:G1MaxNewSizePercent=40 -XX:G1HeapRegionSize=8M -XX:G1ReservePercent=20 -XX:G1HeapWastePercent=5 -XX:G1MixedGCCountTarget=4 -XX:InitiatingHeapOccupancyPercent=15 -XX:G1MixedGCLiveThresholdPercent=90 -XX:G1RSetUpdatingPauseTimePercent=5 -XX:SurvivorRatio=32 -XX:+PerfDisableSharedMem -XX:MaxTenuringThreshold=1 -XX:+AggressiveOpts -XX:+UseCompressedOops -XX:+UseCodeCacheFlushing -XX:ParallelGCThreads=4 -XX:+UseStringDeduplication -XX:+UseFastAccessorMethods -XX:hashCode=5 -Dfile.encoding=UTF-8”



the specific line that you would need to configure