Can't start 1.17 server

So this is my first time using mineos or Linux. I’ve managed to get everything installed on a spare pc I had lying around and the only issue I’m now having is getting a 1.17 server to start. I can create and start a 1.16.5 server just fine with no issues and can load in on a different machine just fine. However when I try to start a 1.17 server from the webui nothing happens when I click start… Nothing pops up, it doesn’t ask me to accept the eula, and the server status still says “down”. If I try to hit start again I get a message in the top right that says “start failed server may not be up when performing this action”. I’m not sure what to do from here. I’ve tried re downloading the 1.17 profile and that changes nothing. Any help would be appreciated.

You need to update your Java: Upgrading to Java 15 from the MineOS Turnkey ISO

Appreciate it. So as someone who’s relatively code illiterate, where can I input those lines in that link? Is there somewhere in the webui?

1 Like

To further clarify, I currently still have a monitor and keyboard plugged in to the server pc that has mineos installed. Do I need to type the code for updating java line by line in the command console on the server pc or is there a way to copy and past the code somewhere in the webui that im accessing from another computer?

so i just tried to input it directly on the server pc and was told “could not open lock” and “unable to acquire the dpkg frontend” as well as asking if im root. i saw in the link you sent that they said they installed as root though i dont know what that means. I’m really not knowledgeable on linux or code in general i was just trying to follow a video on setting up a server using mineos that seemed very straight forward so i apologize if these are very simple and elementary questions.

I would first use PuTTY to remote connect to the server as the mc account. That would a) give you the ability to copy/paste commands, and b) gives you direct access to the command-line interface (CLI).
root is the “master” account that has access to (just about) everything. (Same as the Administrator account on Windows.)
For now, you can gain access to the root account by:

    1. Log into the server over SSH using the IP/user account- most likely mc/password
      (PuTTY works great and supports SSH. Accept the key if this is the first time accessing the system.)
    1. Use the command su and then supply the root password.
    1. When done with the process, exit to making accidental changes

How can this be done with TrueNAS?
After entering the code I get: could not chdir to ‘/opt’

Thank you for any help!

2 Likes

Hi all sorry for being a noob here … i followed the pinned topic on how to update to Java 15 and accepted the eula but i still get no reaction from mineos when i try to start my 1.17 server … any thoughts would be helpful

I’m having the same problem - updated the java successfully - but the 1.17 server will simply not launch. 1.16.5 still works just fine.

Here is a solution for upgrading Java for MineOS on TrueNAS (FreeNAS)

Paste the following line in the MineOS Jail Shell:

pkg install openjdk16-16.0.1+9.1

Make sure your server(s) are stopped.

Hope this helps!

It almost worked for me on Unraid. While I successfully inputed
install openjdk16-16.0.1+9.1
into the docker, it’s asking for a destination file operand. Anyone know what that might be? Thanks.

Hi all,

I tried to install openjdk16 on my mineos jail in Truenas, but at the end I have this message:

=====
Message from openjdk16-16.0.1+9.1:


This OpenJDK implementation requires fdescfs(5) mounted on /dev/fd and
procfs(5) mounted on /proc.

If you have not done it yet, please do the following:

    mount -t fdescfs fdesc /dev/fd
    mount -t procfs proc /proc

To make it permanent, you need the following lines in /etc/fstab:

    fdesc   /dev/fd         fdescfs         rw      0       0
    proc    /proc           procfs          rw      0       0

root@mineos-plugin:~ #

I don’t care about. I launched my server in 1.17 and it started !!! but now I have this error :frowning:

[08:23:29] [Netty Server IO #0/INFO]: [STDERR]: java.lang.OutOfMemoryError: Java heap space

Any idea ?

Many thanks for help
Best Regards
Lalsacien

Hi all,

I will answer to myself. I changed the -Xmx and -Xms from 256 to 1024 and now all is OK.

1.17 server start !

Lalsacien

Hi All,

I also updated to Java 16 (seems 15 got superceded) and now my 1.17 servers are up and running.

1 Like

Great @Bruenore ! :clap:t2: