Cant ssh into server

Maybe someone on this lovely site could give me a hand, new user here and im trying to connect to the mineos I just set up but FileZilla just says

Status: Connection attempt failed with ECONNREFUSED - Connection refused by server.
Error: Could not connect to server

also tried scp similar issue. I have disabled windows firewalls and anything that could be blocking the connection im just not sure, thanks in advanced for the help!

Sorry forgot to mention I’ve tried sftp and ftp and tried ports 21, 22 and 990

EDIT: I’ve also now tried putty to no luck is there a step im missing to enable it first?
I also tried to make another user and connect using it to no luck

sFTP should be using port #22, so either the username/password is incorrect, or the host IP may be wrong. Is this an internal IP or external?

Note your IP address:

This is an address that is likely NAT’ed, which is to say, unless your windows desktop has a ethernet card attached to 10.0.0.x, you wouldn’t be able to connect.

Are you, perhaps, running MineOS in a virtual machine? Virtual machines add a layer of networking (if set to NAT), but VMs can also be set to connect directly to your existing network.

Your windows desktop likely has a “192.168.x.y” address, correct? If your VM had a “192.168.x.y” address, it’ll be able to route properly.

Long story short, take a step back from the network and examine what it is trying to do:

It’s going from a 192 subnet to a 10 subnet, without the appropriate routing; Let’s get them both on the same subnet and it’ll work.