Can't Select .Jar file for FTB in WebGUI

#1

I’ve been struggling with this for a little while now. Essentially when I go to select the runnable .jar file for the server (running FTB revelation 2.7.0) in the WebGui, it will select the option, then immediately change back to “Change runnable jar to:”.
When I click the dropdown again to reselect a jar, there are no options.
See this video:

In the video I only select the FTB .jar file but it happens regardless of what jar you select.

I tried the solutions in this thread: [RESOLVED] Unable to choose jar file and other oddness
The issue is still occurring.

These are the only logs that appear in mineos.log when I try to select the Jar:
{“level”:“info”,“message”:"[Sully_FTB] 10.0.0.40 issued command : “modify_sc”",“timestamp”:“2019-05-22T16:31:19.719Z”}
{“level”:“info”,“message”:"[Sully_FTB] received request “modify_sc”",“timestamp”:“2019-05-22T16:31:19.719Z”}
{“level”:“info”,“message”:"[Sully_FTB] 10.0.0.40 issued command : “modify_sc”",“timestamp”:“2019-05-22T16:31:20.018Z”}
{“level”:“info”,“message”:"[Sully_FTB] received request “modify_sc”",“timestamp”:“2019-05-22T16:31:20.019Z”}

I am able to run the server via jar if I log in as the mc user via SSH.

Permissions on the entire /var/games/minecraft folder are set correctly to be owned by the mc user with permissions at 775.

chown -r mc:mc /var/games/minecraft
chmod -r 775 /var/games/minecraft

I have another Vanilla 1.14.1 server running that has run into this issue every now and then, but it was resolved by fixing permissions.

I also tried loading up a fresh version of the FTB flavor I’m running, and I am having the same issue.

I got to the point where I was trying to find where these server settings are saved on the system drive so I could just set it there myself but I have no idea where that info is stored.

Any help would be greatly appreciated!