Can't see web ui [solved]

The connection to {server} was interrupted.

The port test as open (and shows closed if I stop the mineos service.)

I finally decided to install on host os (centos 7) rather than vm because no one seems to be able to help me configure port forwarding. (Yes I can port forward a router, no I can not configure firewalld or iptables apparently. The server is Internet facing there is no NAT. The server has a Public IP Address. I feel like i should emphasize this because it seems to really mess up some people. The only firewall between this thing and the Internet is the software firewall (currently back on firewalld) )

But I will deal with the vm issue in due time. Right now I just would like to see this running period. Any log files or what ever else might be helpful upon request.

Thank you in advance. I would love to see MineOS up and running on my server but I have been having a lot of trouble seeing any results…


Okay. I should have caught it sooner… But im still a little frustrated about the whole VM thing not working. I should have caught… I just didn’t manually type https:// in front of the address… Thanks guys.

Just for clarity, are you sure your server has a public IP address? When your server has a public IP address, port forwarding is no longer required. Typically, only the modem/router has a public IP address and servers themselves have private IPs, which are forwarded.

Forwarding and public IP address on the server host itself isn’t ever used in conjunction with eachother. Anyway, just a little nitpick.

Yes my server has a 69.XX.XX.XX ip address. internet facing, no NAT between it and a gigabit fiber line just a few switches. The port forwarding i am talking about is referring to more of a… virtual NAT if you will transferring incoming traffic on the host OS to the VM.

(if I use “ip addr” command em1 prints out 69.XX.XX.XX which is the same IP I type into my browser on and off network)

Pardon my asking for verification. The overwhelming majority of MineOS users are home-hosters, never assigning IP addresses to their server (because they don’t have dedicated ips) and the exceptions typically aren’t running NAT–simply running the webui on the host directly.

What you’re referring to is more commonly known as ip forwarding, rather than port forwarding–and is often addressed with utilities like pf, a packet filter.

I don’t particularly care for rhel/centos as a matter of preference, as when I want to have that level of granularity and control I typically spin up FreeBSD instead. FreeBSD jails is an example of creating a NAT which mimics what you’re doing except with jails, not a vm. If FreeBSD is an option, I actually already have documentation to make that work in the wiki (see jails in the wiki), but if not, we’re you working with sysctl ipv4.ip_forwarding?

Pardon my poor terminology, I am fairly new to all of this. I can find my way around it all fairly well but mix up my terms a bit. Live and learn, so thanks for the explanation.

Well in CentOS7 they shut off iptables, and switched to firewalld. Which I have basically been told that… firewalld will not be able to do what I need it to. I actually work with a a full type sysadmin that strictly uses CentOS for server. So I went with it so that I would be able to get the most help in person as possible. Plus I have always loved fedora personally anyway so I have had the most experience with rhel.

I have tried switching back to iptables but I would be lying if I said I had any idea how to use that.