Can't run/start a new server

I have run my server for about a month now, and had minor, easily-fixed problems. but now I have come across a problem that I can’t get my head around, I cannot at all create any new servers I have tried different versions and more. I have accepted EULA and everything is exactly the same to my older server, except when I start up the sever it says it has started but then it just says it has stopped. Does anyone know a solution to this problem? It is getting to frustrate me right now! Thanks!

What does /var/log/mineos.log say about your attempts to start a server?

Are you using a non-root user, e.g., mc? (You’re using MineOS turnkey, correct?)

Have you made any other changes to the OS such as trying to update Java or anything else that came before this problem? Have you been doing any file-system things as root?

Root does not work for most things apart from the code from the computer that runs it. I always use mc to logon to MineOS and File Manager. Correct I use MineOS, Turnkey. /var/log/mineos.log dosen’t say there is any problems as far as I can see. It says: issued command : “start”",“timestamp”:“2016-02-13T18:50:01.019Z”}
Then: received request “start”",“timestamp”:“2016-02-13T18:50:01.019Z”}
It dosen’t say anything else to do with start/stop command. I just start the server then it says it has stopped again.

Have you looked at the server logs in /var/games/minecraft/servers/“your server name”/logs , look at latest.log , if that doesnt show any problems, try looking at the previous logs also .

Okay I’m away at the moment so I will look when I get home in a few days. Thanks

There is no latest.log because the server has never been able to run. I have the other server but thats fine it’s just every time I create a new one. I only have two servers. one is the one that is working and the other is the one that never has, I have tried re-creating a second server lots now but still dosen’t work : (.

Log in as mc to your terminal.

cd /var/games/minecraft/servers/xxxxx
java -jar minecraft_server.1.8.9.jar

Put in your server name that doesn’t work, in place of xxxxx
Put in your server jar in place of minecraft_server.1.8.9.jar if it differs. What does your screen say now?

Sorry, I worded this wrong, I’m not having a problem with creating the server I’m having a problem with running the server. Everytime I click the start button on a new server and it just stops. Sorry about that.

Yes, and the instructions from my most recent post is attempting to address the server you are trying to run but are unable to.

Okay, I will work on it now. Thanks

What .jar file would I use for forge 1.8? Thanks.

You need to apply a little more critical thinking to get this working; there’s only so much I can help you, but the .jar file that you have either a) selected as a runnable jar or b) was listed one command earlier with ls is well within what you should be able to figure out.

From what I can gather here, you seem to not be using a proper Minecraft Server Jar file.

Enough Said. Here’s the solution to your problem (you may have to click on the following post to view the whole thing)

Wasn’t that difficult to figure out :stuck_out_tongue: >.< lol It’s unrelated to the UI, because the UI does it’s job of running the jarfile (or the UI would’ve probably said that starting the server has failed).

Extra info:
From knowledge and similar experiences: attempting to run a non-server jar either does not work, or does not work correctly (usually will not work). An example: back before the Node based UI was ready (when everyone was mostly on Python based UI) attempting to run Spigot’s BuildTools from the UI as a server would not work, I haven’t attempted this on the Node based UI since it does have it’s own dedicated section, although I still run that via commandline. Attempting to run Spigot’s BuildTools from the Python UI as a server would essentially throw you the same “problem” of “not starting” or “starting then stopping”. I assume the same would occur when trying to run a raw forge jarfile (universal forge, or forge installer) does not work and will give you the same “problem” because of it being an invalid Minecraft Server Jar file and needing something extra to work.

In the end: It isn’t a bug in either one of the UIs, and is just jar requirements.