Can't play externally

I have a separate machine set-up with MineOS Turnkey on it. It has a static ip, the port 25565 is forwarded. I can connect to the web-ui via my external ip, and change settings etc. but for some reason, when I connect to a Minecraft server running on it, the server and client are desynced (i.e. can break blocks, not dropping items) and after a few seconds it disconnects me. It also usually takes a long time on the downloading terrain screen. It gives the error “a remote connection was forcibly closed by remote host”.

It sounds like you are connecting, so the forwarding is as it should.

Could you please provide both minecraft server log and mineos log?


I had the port changed for testing. Started up the machine, changed the port back to 25565, stopped the server, restarted the server, tried to connect, got into the world, world did not load, got disconnected, stopped the server.

I can’t really see anything in your logs that indicates any problems with neither server nor world.

I suspect a network related issue that causes your client to fail to sync with your server.

You say that you connect via an external adress, but your logs indicate that you are connecting through LAN, and not Internet?

Are you using WIFI (wireless networking) to connect both client and server to a network?
If you are:

  • Do you experience unstability or slowness while doing other tasks (like browsing, streaming video and so on)?
  • Have you scanned your area for other wireless networks? If a lot of networks try to share the same channel, you get lousy signal (even thoug it may show up a strong) due to interference and signal noice. Tip: try to change channel on your wifi router.

If you are connecting from the internet:

  • Have you tested your internet speed? And is your internet speed stable? Or do you experience high LAG?

My main pc, with I am connecting from is on the same network as the machine running MineOS, I am however connecting via my external ip, to test whether connecting from the outside was working. When connecting via internal ip everything works fine. The ip in the logs,, is my router’s LAN ip adress.

I got a friend to see if he could join, and everything worked, so it must have something to do with me being in the same network I guess. But I can use the internal ip anyways so it doesn’t really matter. I still find it strange though.

He’s probably not joining using the IP–because that’s meant for in-network connections. When you’re attempting connecting from outside your network, are you using your routers WAN IP address?

Yes I am. Or rather a url that links to my router’s WAN IP using DNS.

Whenever you decide to use your WAN/Public IP address to try to connect to something within the same network (or test port forwarding) it usually shows your router’s local IP instead of your device’s local IP. However I never had a problem staying connected to my server via the external IP while being on the same network, and now instead of using the internal IP for my server, I use the external when I’m out and when I’m in.

The problem must be your router then (it’s firmware and/or it’s settings) but since you can connect using the internal IP and everyone else outside with the external IP there’s no reason for me to suggest a way to fix it.

I suspect it’s your modem, but I can’t think of a way to prove/test it.
I had this problem when Comcast tried forcing me to update to their modem/router combo. It didn’t like traffic that was leaving the house and coming right back.
I switched back to my original setup with separate modem and router and told Comcast I wasn’t upgrading.
It is annoying not being able to test your own connection. You can use to test the port, but it is nice to actually know it works.