Can't login anywhere else than WebUI and restore mode for debian

Hi! I can’t login to putty, it says access denied, I also can’t log into FileZilla and to mineos login when I start the server. I tried to log in as root, edited sshd_config to say PermitRoot Login yes (or something along those lines I looked up), but still, I only can log into webui and system restore debian.

Is this from the Turnkey ISO? Or did you install a separate debian distro?

What do the logs say in /var/log/secure (maybe exists in debian) or /var/log/messages regarding the attempts?

is it debian 11?

It is on separate Debian distro, it is on Debian 11 indeed.

var/log/secure does not exist

var/log/messages has something near 2000 lines, I tried to find something regarding loging in, and I just ended up with a headache. But I remember that it started happening after I have set password type to sha512.

Did you reset password after setting SHA512?

Might be worth doing it again just in case.

yes I did. I installed debian 10 instead of debian 11 and everything works perfectly fine. I just can not join from outside my LAN, even when I port forwarded. G
oing to do some research on that.

Might be debian firewall and needing to open those ports.