Cant load web ui. (connection refused)


#1

please take note… i never used linux before so this is quite new for me.
so i installed mineos on a xeon x3430 server and im trying to load the web ui using the correct ip and port… but it keeps saying connection refused… so went ahead and disabled the firewall on linux and the pc im testing it on and it doesnt work… pinged www.google.com and no issues so the server is deffo connected… any ideas?
again sorry for being a noob…


#2

A usual error is to forget the “s” in https//[serverIP]:8443. The MineOS webserver are unfortunately not able to pass on a http (unsecure) connection to a https (secure) connection


#3

when i log in… is a elf header error normal?
the exact error is this
https://imgur.com/a/MElOPMl (it feels important so i better ask)
tried to use https but still connection refused. (just tried a reinstall on another hard drive. same errors)


#4

https://www.youtube.com/watch?v=3JwuFZ0jKE0 just found this video… noticed after the update thing i never get the configuration console… i just get kicked into the typing thingy (terminal?)
after reinstall using a older iso… it worked… showed the core appliance services screen… now still connection refused…


#5

Seems like you’ve downloaded and installed the old legacy/outdated python version based on those .py errors rather than the newer and more current nodejs version. Okay it’s seemingly unrelated to the MineOS webui being that you’re using/running Debian Jessie and the tracebacks don’t point to where the MineOS webui would be located, so I have no idea what those are for or about.

The correct port for the older legacy and outdated python would be 8080, so connecting to it would be via https://<IPaddress>:8080 rather than the https://<IPaddress>:8443 used in the current nodejs version. [try port 8080, won’t hurt to try and you never know it just might work based on those tracebacks]

Your options would be to either stick with/use the python version (which I would say would not be recommended by the majority of us) or to switch to the current nodejs version.


#6

Well, the screenie definitely shows me that you’re using the most recent ISO, because Jessie is the current Debian release of MineOS, but I’ve never seen such an error before…

Did this show up right from the get-go? Did you do any updates to the distro (not expected that you would have, but wondering if that introduced this error)?

Do a supervisorctl status mineos–does it return that the service is running?

netstat -ntlp as well, does it show there is a server currently open on 8443?

Is your server pingable from a different machine at your 192.168.2.19 ip?