Can't install MINEOS turnkey

the link on the download page downloads but it freezes when it brings up the partition manager. I have tried all the different iso to flash drive programs and settings. Where can i find an ISO that works that is not broken? I remember the OG one from 4 years back just worked and now it doesn’t.

Have you used live media to check your disks? Do you know if they are partitioned already? Partition the disks at the terminal using something like fdisk or gparted look over the disk and what they are doing this can be an issues sometimes and sometimes even formatting the disks from terminal will fix it.

I have even seen instanced where i have had to setup disk partitions exclusively in the terminal because the GUI won’t proceed for what ever reason this was a while back so i can’t recall exactly i just recall having to do it manually.

i guess outside of that you want to go towards fsck just to rule out any issues.

ill post a picture of where it freezes later on today.

Where can i find an ISO that works that is not broken?

Every MineOS Turnkey image I construct and publish online I test and verify installs in a virtual machine. Every one. That’s also why I don’t update the ISO super frequently, because I like having the assurance without having to install MineOS every few commits.

I would attest that the issue you’re having relates to the ISO->Flash Drive change.

What program are you using? Balena Etcher worked fine for me, and I stopped using rufus ages ago.

I have tried all the different iso to flash drive programs

Which have you tried so far, so I can test?

Alternatively, rather than continuing to chase after a successful combination of ISO/Flash drive program, have you considered the other ways of deploying MineOS?

I have tried: ISO to USB, Balena Etcher, Free ISO Burner, Rufus, and UNetBootin, I even tried from my Ventory flash drive all fail in different ways.

I had changed setting from UFEI to BIOS mode on both the writers as well as the server itself. I have even left it alone over night once.
The Pictures that are attached is from me trying it just a little bit ago after using BalenaEtcher. Picture One Picture Two

Now that I’m re-reading, I realize how extra bizarre it is to be crashing at the partition manager, rather than what most people’s experience is, which is it failing to boot the media at all.

Seeing as how you’re getting that far, the ISO-to-USB method is probably moot at this point. The difference between an incompatible flash drive imaging (e.g., not DD mode, etc.) should be whether it boots anything, or nothing.

With it loading that far, it’s much more likely that the partitioning of the drive is causing issues (follow @Ank post above) or that MineOS Turnkey doesn’t have the support for the system you’re installing on (driver, etc.). The good news is that most certainly a lot of distros do, and for each of them, you can install MineOS.

To that end, it would probably take 1/10th the time to install Ubuntu server and do the installation of the webui.

I am not entirely sure either but i do recall this happening to me in the past like maybe a few years back all i can remember is i spent time trying to debug the issue in live media trying to find the problem trying various flashing programs etc. I recall not really knowing why it was happening because everything looked uniform but i think formatting from the live terminal fixed it. It would get to 100% but would not complete the partitioning.

I think this was not even on MineOS turnkey either and i feel like i was doing something else unrelated but again fuzzy on it.

and i recall roughly having to use terminal because the GUI for what ever reason was bugging out like it wouldn’t save any partition changes via GUI idk exactly but i just remember that i had to do live media.

Do you have a script to configure it like you had before? I was looking for debian or Ubuntu server 22.

Ubuntu Server 22.04.1 and Debian -11.5.0 so if you got a script to do it since i was having issues going this way as well.

What are the new issues? The wiki is all you need to follow wiki

Common problem for recent distros that want to run MineOS is yescrypt.

Ubuntu Server 22.04.1


I just ran into this when following the guild.

image

The highlighted part is when I put in that gave me this error.

I’m running this all through putty.

you need elevated rights to do that.
Use “sudo -s” first, then “npm install” again

I’m in root mode right now after I did “sudo -i” you can even see it in the picture I posted last.

Well, it seems your commands are sent as a non root user:

strange indeed check the ownership of that directory? i mean root should be system wide but idk maybe something is messed up here? you cannot even mkdir either which means there is a permission problem.

Did this work because I can’t tell. pic

yes

nvm lol my bad its late here ok but yeah it worked

It was having issues doing that and the site acts weird this morning. around 7 in the morning CST.

I couldn’t post or view and the site acted like it was down.