Cant host server above 1.11.2

#1

Hello, this is my first post, so sorry if I did something wrong. Yesterday I had finally gotten around to putting MineOS on to an old PC (HP Slimline s7415c) I had gotten from a friend. When went to download the ISO file, I had to get the 32bit version, which did not come with OpenJDK 8, which I have found from another post is the reason behind why the MineOS webpage won’t start a server above 1.11.2. So I have spent a long time trying to figure out how to download openJDK8 for Debian 7.11. Everything I have tried did not work because when I SSHed to the server using PuTTy, and typed “sudo add-apt-repository ppa:openjdk-r/ppa” or anything else with “sudo apt-get” I get this “-su: sudo: command not found” I am just getting started with all this Linux stuff, and have no clue how to fix this. I did do some googling, but I could not find an answer. If anyone can tell a different way to update the OpenJDK 7 to 8, I would appreciate it, or if anyone can help with my current problem, I would appreciate it.
FYI: I had downloaded the MineOS ISO file from https://minecraft.codeemo.com/mineoswiki/index.php?title=Main_Page#Pre-configured_ISOs
and downloaded the previous 32 bit ISO because there was not current 32bit version listed.

#2

Man, the 32-bit version hasn’t been touched in so long. Perhaps I didn’t even include sudo?

You can add it with apt-get install sudo.

But alternatively, you could just avoid sudo altogether–"su -" and then type in your root password. Then sudo no longer is necessary because you’re already root.

#3

OK. I have typed in “su -” and my root password. Then I type in “apt-get install default-jdk” or “apt-get install software-properties-common” or “apt-get install oracle-java8-installer” and I Just get E: Unable to locate package… Am I doing something wrong? I don’t understand why any guide I try and follow on how to download Java 8 for Debian 7 just leads me to this point. Is anyone able to point me to a guide that works? Does this have anything to do with the recent Oracle Java License Update back on April 16, 2019?
I have tried these guides:
https://www.digitalocean.com/community/tutorials/how-to-install-java-with-apt-get-on-debian-8 - (I know the Debian version is 7.2, but figured that this would not change things)
https://tecadmin.net/install-java-8-on-debian/ - (I know that it says that Java 8 is no longer public, so would following there a guide for Java 11 on Debian 9 work?)
http://www.webupd8.org/2014/03/how-to-install-oracle-java-8-in-debian.html - (I realize now that this one says that the PPA links are broken because of the License Update)

I have spent many hours trying to troubleshoot, and at this point am about to just give up with the 32bit turnkey ISO and trying to update Java to 1.8 and try something else.