Can't find external IP for MineOS PC

So I installed MineOS on another pc as its own OS, no virtualbox, and there’s no other OS’ on it. Everything went smoothly, I’ve imported server archives, made an RSA key, and I can connect to it through LAN, but I can’t find any external IP to connect to it through online. No one seems to have this problem and Im starting to think it’s just because I havent installed MineOS with a Virtualbox. If someone could help me out I’d really appreciate it.


1 Like

Have you opened your IP Tables on the Linux box? The fact that you can connect from your internal LAN would seem to indicate it’s fine.
Have you port forwarded your router?

I’m not sure how iptables helps my issue, that pertains to the firewall, where my problem is I actually can’t find the external IP in the first place. I have the standard one that works, but how can I allow people to connect online?

And yes I’ve port forwarded, the problem is I don’t have any IP for my friends to even input.

On your router settings page, usually, it will list your current IP. Or you can type “what’s my IP” in Google and get the same result. That’s what your friends will use to connect to your server.

Unless you have a static IP from your ISP (most people don’t) this can change from time to time. My Verizon provided IP changes whenever my router is reset.

Hope that helps.

And you can use a dynamic DNS service that can help get around the ip changes.

Okay so that IP would be the one my friends can connect to. Trying that it doesn’t work, so does that means it’s a firewall issue? Once again im not using a virtualbox, the pc is completely using MineOS as its OS

Ok, which port have you forwarded in your modem/router? Does this port match the one you’ve assigned to your minecraft session?

25565, ive forwarded it on my router

Double check the IP address of the forward and the address of your mineos machine.

If you can connect locally it’s not firewall. You could disable iptables temporarily if you wanted to double check. It’s likely a port forwarding issue.

Do you only have the one device (modem router) between your computer and the Internet?
Does your device require saving and applying the port forwarding rule?
Have you tried resetting your modem router?

1 Like

What router are you using? I ask because Verizon’s Actiontec router is annoyingly complicated for port forwarding and it took me a few tries before I got it to work right.

I wouldn’t think it a firewall issue. My server, when it was working, connected to the web out of the box.

I take that back. If the modem/router firewall is blocking port access you can still access the machine locally via the 192.###.###.### net.

I don’t know what your regular computer is (OSX, Win, Linux) so I can’t give you a CLI option but there are web sites that check if a port is accessible from the web. or are two that I’ve used.

All figured out now, the IP for the port forward was instead of, once I got that working it was all good, thanks for the help fellas :smile: