Can't download Profiles


#1

Hey, I’m new here
So I’ve created a VM with MineOS where everything’s work fine (Internet, etc) (p.s. i’m using a 32bit machine)
When I went, in the web-ui, downloading profiles I went to the profile section and nothing was shown
Can you please help?
Update: Now I’m seeing these ones. I’ve tried to download all of them and start, but it won´t do nothing, so i just deleted them from the profiles dir.


#2

Try restarting the webui service:

Instructions on the wiki (choose a different page if you aren’t on ubuntu/debian).

If this doesn’t solve it, share with me /var/log/mineos.log


#3

Thank you! It worked
But now I went to create a PocketMine server but idk how to start it, i’ve downloaded the .phar and the php files on the profile section but I just can’t figure out how to run it
Can you help me or should I start a new thread?


#4

Pocketmine, and other non official pocket / console edition servers, is not really worth the hassle trying to get it working. Iv’e given up on keeping up with the current working version.

The shrot of it is that there exist no FULL version of pocketmine that support the full game experience. You end up with a below vanilla creative multiplayer server, without mobs. You server will also only work until Mojang releases an update to the game, then you have to either have all your players wait to update their clients, or have a server they can’t connect to untill one of the developers of pocketmine or the clones push out a new alpha version that works with the clients.

Oh and I said alpha version. The pocketmine style server are ALWAYS lagging behind. They never get ahead, so before they get a full feature stable version out, mojang has updated again, so all pocetmines are alphas. And since they scramble to keep up with the official version, they never get ahead enough to add things like AI and mobs.

Now, if we could just get Mojang/Microsoft to release their Realms servers for local installation and play, it would be another story. But Realms is a paid solution, and forces everyone using it to pay every month. Them releasing a free server is not likely at all.

Now, after my rant about why I gave up, you still want to run a pocketmine the profiles wont help much. You’ll have to to the work manually.

You can download the latest working phar here: https://jenkins.pmmp.io/
You need the latest file from under “PHP-7.2-Linux-x86_64” and “PocketMine-MP”
Then you need to copy both files over to our server directory manually (using an ssh-ftp program like filezilla), then unpack the archive containig the php files using the command “tar -zxvf [filename]”.

Once you have the php files installed you probably do not need to update them the next time releases an upgrade. You usually just need to doenload and transfer the latest phar to your server direcotry. It may take everything from a few days to a few months before a new phar that works with the latest mojang release show up though.


#5

Yeah, you’re right in that, but I just can’t find any server software for bedrock better than this, since Nukkit has a lack of plugin developers.
Anyways, I’ve done all what you’ve said but it gives me an error when I went to start it:

{"base_dir":"/var/games/minecraft","archives":[],"owner":{"uid":1000,"gid":1001,"username":"mc","groupname":"mc"},"du_awd":4096,"du_bwd":4096,"du_cwd":null,"level":"error","message":"[bedrock_alc] Error with get_page_data { [Error: ENOENT: no such file or directory, lstat '/var/games/minecraft/servers/bedrock_alc/\u0001P�\u001b@@��@8']\n errno: -2,\n code: 'ENOENT',\n syscall: 'lstat',\n path: '/var/games/minecraft/servers/bedrock_alc/\\u0001P�\\u001b@@��@8' }","timestamp":"2018-03-03T23:14:11.989Z"}


#6

It fails trying to open a file at this location. for setting “level-name” , what have you put? Any special local characters?

The servers really just accept english normal numers and letters


#7

Hmm I think it is because of this (the stranger letters file)… Because I have named the level ‘world’ (the default) so that isn’t the problem


#8

IT’s a zero-byte file. Have you tried deleting it?


#9

Yeah, I’ve tried going on SFTP and delete that, tried with SSH (rm command) but nothing worked
This only happens with pocketmine and probably with any other php minecraft server client based. Guess I’ll have to use nukkit


#10

How did it not work? Wouldn’t the file be deleted? Or did it get recreated?

This may of course be an bug or artifact from the latest version of either the php-binaries or the latest phar. That is kinda the risk of riding the cutting edge needed to keep a Poketminesstyle server working with the different phone/pad/console editions…

I’ll see if I can get a new server running, and archive it so that you can restore a working version to see if that works.


#11

I can’t even run Nukkit, only mc java edition server clients


#12

OK.
Try downloading this file: http://nik.melsom.be/configuredPocketMineMP.tgz
(It’s an archive of a working pocketmine MP server, tested against the most recent Windows10/pocket edition client)

Place the file in /var/games/minecraft/import"
Then use the “import a server” button to install the server. ’

It is configured with whitelisting, so to allow users to connect use “whitelist add [username]” in the input line at the bottom of the log viewer.

It also comes with a bit of build, as it is an archive of an existing server, if it works you can reset it by deleting the “world” folder.


#13

Still not working
Yesterday It worked with java PC versions but today even that doesn’t work. And the server you’ve sent doesn’t too.
Back to yesterday, I’ve installed MineOS on a old computer (with 2gigs of ram, but on the web-ui only shows 512mb idk why) and firstly I’ve created a java pc server and it worked. Today the story is different, any type of server not working.
When I was starting the server you’ve sent me, all the executable files disappeared on the profile chooser but they’re still there on SFTP/SSH
Idk if it my pc’s fault, the fact that it is 32bit or the bug of ram only showing 512mb instead of 2048mb (2gb)


#14

I think I’ll have to summon @hexparrot to help here again.

I know the server works because, as I said, it is an archive of an exisiting server. I spun it up and tested it before sending. Ikan even spin it up again, providing you a test link. So there is definately osmething wonky at your end.

Could you pastebin your /var/logs/mineos.log please? (www.pastebin.com). Your log may help us root out any problems.

You are absolutely certain your computer and processor is 32bit only? a lot of processors bundled with a 32bit windows where actually 64bit. It has to be really old not to be a 64bit processor

Have you tried to update/reset the WebUI / Mineos installation?
update:

cd /usr/games/minecraft
git fetch
git merge origin/master

reset:

cd /usr/games/minecraft
git fetch
git reset --hard origin/master

#15

Now I’m not at home, but on Tuesday I’ll be back. But I’ve updated the web-ui as you say there. Next Tuesday I will say if it worked or not


#16

We definitely want a copy of your /var/log/mineos.log. It could be as plain to error logs that those special characters are still present and messing with the webui, and I can definitely see about what it would take to handle that gracefully (rather than the weird behavior you’re getting).

I’m going to guess that what snippet you provided at the start, though, is just repeating over and over.

It’s likely the node.js modules watching the server directory have no idea what to do with u0001P�\u001b@@��@8…and I wouldn’t blame em. But there’s likely a way for it to progress without constant errors which could be crippling the UI.