Can't create new profile

Hi there,

I am trying to add a profile to my profile manager. The problem I am having is that I do not see the control (create profile, I think it’s called?) that allows me to create a new profile. I have tried to log in as Root, and MC, but no dice. What am I doing wrong?

here’s a screenshot

Thank you!!

With the webui that is most current (now written in nodejs), you do not create profiles. You can either download existing ones from the pre populated list or you can simply upload the jar file you want to the server directory itself.

Once the file is in the live directory (see the server status page), it can be selected in the “runnable jar” drop down on the same page.

Functionality to upload files from the webui does not currently exist and is not currently in the roadmap, but may happen someday, so in the meantime use an sftp program like FileZilla if you need something other than those provided.

Love the new version, have it running paralell in test with my production server.

The “runnable jar” list seems to not populate in my instance, so I cannot select any Jar from any of the existing servers. I created a new server (aptly named “test”), and it populates with the correct mojang JAR after downloading mojangs latest release. It works.

My problems seems to be that JAR files from server directories from the old MineOS isn’t loaded. For the most part this is not a problem, other than for my bukkit-server, that do not have a profile I can download from.

It is a fresh install of MineOS on an Ubuntu server, the only “weirdness” I have chosen to do is to connect the /var/games/minecraft directory with a CIFS connection to a windows folder (fileserver with several Terrabytes discspace available)

Thanks for your reply. I’ve connected to the MineOS vm by FileZilla. What is the directory path of the folder that runnable jar files go into?

The “live server directory” as noted in the server status page. (right under the runnable jar dropdown)

Hi all,

I have had a MineOS server running for my daughters for some time. I just set up a fresh one on a new server from scratch with the aim of haning over admin to them (they are 10 and 12). I tried importing an existing server and had no luck. Also I was unable to create a new profile (as the option no longer seems to exist) and after SFTP to the appropriate directories it doesn’t appear in the profile dropdown list. As it does not appear in the list, I can’t change the runnable .jar file to the one that I want. If anyone knows a work around in the mean time I would appreciate it. The youngest one turns 10 tomorrow and I promised her a new server with a whole bunch of mods, and whilst I know my way around linux a little, I can’t seem to find where the file which lists the different profiles is situated, otherwise I would just add the server profile and .jar files with a text editor. Many thanks to all who have worked on MineOS. Its a great easy way for the kids to have fun.



I’ve been getting scattered reports of imports not showing up right after importing, but showing up after–for example–closing out the webui and reopening it.

Can you try that to see if it resolves your issue? That aside, I’d happily look at the import you’re actually using and test it to see if there’s anything I can do on my end to make it work as intended, which is to say, to immediately populate the server with the jars you expect. If you’d like to try that, please let me know a way we can make the exchange that is good for you.

Hexparrot, thanks for your prompt reply. I have tried closing the webui, and opening in both chrome and firefox but for some reason I cannot create a new profile. I managed to sus out the import part after zipping the server, but when I create it from an archive (using webui), it will only let me choose profiles from the list of those available when I built the new server from scratch using the new ISO, and then only the .jar file associated with the particular profile, be it a mojang, FTB, bungeecord, etc. Unfortunately the .jar file associated with the import has a series of extra mods and I can’t change the runnable .jar to that file. I am unable to find a way to create a new profile that lets me choose the appropriate .jar file and unfortunately I don’t yet know enough about how MineOS is structured to be able to edit the file which contains the profile list (i.e. mojang, FTB, bungeecord, etc) otherwise I would give that a go.

The import is based on 'Natural Magic by WTFGeeks which is a 1.7.10 based server that she downloaded using ATLauncher after seeing the following Youtube Video. Not too bad for a 10 year old, but at 48 I now feel like a fool because I thought it would be a synch. I also thought it was about time they started looking after their own server a) to save me time, and b) to get them to learn a little about linux.

Rather than taking up too much of your time trying the import however, perhaps if I understood the way the newer version sets/lists/creates the profiles I could add some of my knowledge to the project for everyone’s benefit. Otherwise she will keep bugging me…

If necessary you can get in touch via graeme.baume(at)gmail



Let’s first thing about what profiles did (in terms of the Python webui):

  1. downloaded a file from a URL.
  2. extracted that file/copied that file to a directory /var/games/minecraft/profiles/name
  3. copied that profile to /var/games/minecraft/servers/servername
  4. defined what file will be run to start minecraft

Here is the equivalent experience in the nodejs based webui (assuming a profile exists):

  1. downloaded a file from a URL.
  2. extracted that file/copied that file to a directory /var/games/minecraft/profiles/name
  3. copied that profile to /var/games/minecraft/servers/servername
  4. the user selects which jar within the directory to run

And finally the experience in nodejs (assuming no profile exists):

  1. ensure the jar file exists in the server directory /var/games/minecraft/servers/servername
  2. the user selects which jar within the directory to run

Creating a profile does wouldn’t make it any easier to choose the appropriate jar file. It’s still a requirement for you, the admins (and your children) to know which jar file will run. If you could create a profile, it would ask you what jar file to run, as well–so it’s really just about replacing “must know at time of creating profile” with “must know at time you start server”

You might, on one hand, be suffering from an issue where the jar file isn’t showing up in the ‘runnable jars’ dropdown. This should 100% be fixed by a number of things:

  1. rebooting your server OR
  2. restarting the mineos service OR
  3. choosing the ‘refresh server list’ from the dropdown at the top right
  4. closing the webui and logging back in

Upon any of the above routes, the ‘runnable jar’ dropdown will be refreshed and you should see all .jar files available to choose from. Closing the webui and changing browsers will not, however, give you functionality to create profiles. Creating profiles is no longer a thing.

Hexparrot, thanks for your detailed and prompt reply. I did not realise that the create profiles function had been removed. I can understand why given that the purpose is it is to make it easy. Understanding the change that has been made should give me enough to work on. If I have any thoughts I will let you know. The girls have just been asking me about this or that mod, etc. (which is why I was thinking of handing it over to them after setup) Thanks again.



I’ve run into the same problem, and done all four of the options for trying to fix the jar list not being populated. Still nothing shows up. I’ve even tried downloading some of the preloaded options to see if I could get them to show up, nothing.

Specifically I have forge-1.7.10- in the /var/games/minecraft/servers/RR directory. It’s under MC permissions list, and I log into the mineos at port 8443 with the same login as I FTP’d to.

At quite a loss, thanks for any help you might have.

Tell me more about your system. On what distro did you install this? Is this the only server on your list? Was it an imported server or created from the webui? Are there any apparent other errors on the server status page?

Can you share /var/log/mineos.log?

This was a fresh install using the NodeJS based MineOS Turnkey 64 bit preconfigured ISO. Only server on the list, and I checked to make sure the various directories were all empty as well except for this. Everything else looks right, or at least I’m not seeing any other errors.

Here’s a part of the log, the most recent. The entire thing is a bit unwieldy for pastebin.

I need a bit more. If the first time this issue cropped up was before 5am today, then it’s likely to show up in the logs before the start of where you gave me.

Ah, sorry. Here’s the oldest I have in the log. I tried uploading several different server folders to see if any would work.

Okay, I tried a fresh format with turnkey mineos and moved the server via FTB with mc access, then moved via root access.

Now the mineos doesn’t load at all, which I had as a problem before. A lot smaller log this time.

I think then the problem lies entirely on the server that you’re trying to import. If you can dropbox me a copy of that server, I can probably reproduce your issue and fix it once and for all.

Of course, based on the logs, you might be experiencing an issue I think I already fixed in a commit (but on that happened after the ISO).

So where possible, if you can do the following things:

  1. give me a copy of your server zipped up or archived etc.
  2. update your scripts and see if it fixes it.


  1. fresh install MineOS, update the scripts FIRST, then try loading your server.
    If this works, I know I fixed the issue at hand, and will just re-create the ISO with the new commits.

Did the fresh install, updated scripts with the following.
cd /usr/games/minecraft
git fetch
git merge origin/master

Then tossed the server on and checked. It doesn’t crash the webui this time, but it still has no selectable jar.

Here’s the zipped server file. I appreciate the effort you’re taking for this problem. It’s been driving me a bit batty.

Alrighty! First I want to thank you as well for putting in the effort to let me know what you’ve been trying, in reproducible steps, along with the large server files themselves.

In the end, it turned out that the issue was that the /archive/ResonantRise and /backup/ResonantRise directories weren’t being created when you moved in the /servers/ResonantRise directory.

This caused the directory size checks (on the server status page) to fail, and they happened sequentially before the list of server jars.

I have corrected this in a new commit, which should allow you to have done exactly the steps you did and it show up immediately in the webui (both the server, and all runnable jars).

Update your scripts again using the commands from your last post (fetch, merge) and restart the webui. This can be done with:

supervisorctl restart mineos

or by restarting the whole host.

Excellent, that solved all the problems!

Thanks Hexparrot.