Can't Connect to my MineOS Server

Description of the problem:
I’ve have tried multiple times on multiple different computers to try to connect to my MineOS Web UI with no avail.(they have all been connected by Ethernet and I have pinged so I know they are connected to the Internet).

Video for clarification:

Basic Information about the environment:

Which distribution are you using?
A fresh install of the MineOS Turnkey ISO.

Have you updated the web-ui since experiencing this issue?
I ran the command apt-get update, so it should be all updated.

Has this issue always existed or did it appear over time?
It’s always been there don’t know how to fix it.

How can this issue be reproduced reliably?
Yes I have tried setting up the turnkey on three different computers with none of them letting me connect to them via the Web UI. I also have tried pinging them at 192.168.X.XX and was unsuccessful.

Disclaimer: I am completely new to the Linux environment so I would prefer a very basic explanation.

Watching you video when you go to the second computer and enter the IP address and port number your browser reports “connection refused”. Your computers are able to talk to each other but the connection is refused due to the server firewall rejecting the connection. At least that’s my working theory.

This guide should fix your issue

Edit MineOS Turnkey should have the necessary ports open by default.
Check which ports are open using
‘iptables --list’ command.


Another thing to check–you aren’t able to ping inbound to your MineOS server, can you ping out?

From your MineOS server console, ping your desktop machine.

Also from your desktop machine, ssh to your MineOS server.

1 Like

Update on the situation: I still can’t connect to my server via WebUI. I am still getting the error message This site can’t be reached refused to connect. I did what Zone suggested and I ran the command iptables --list command and it looked as if everything was set to accept, but I still couldn’t connect so I ran the commands iptables -P INPUT ACCEPT. Which on the guide it said this would accept all traffic by default. Then I thought it might be a problem on my computer’s end so I disabled the windows firewall and windows defender. I still couldn’t connect. I then tried to ping my computer from the MineOS server but it did absolutely nothing when I ran the command ping Then I tried to ssh to my MineOS server which worked and let me log in via mc and my password. I don’t know how to use this to help me connect via WebUI so I am still stuck and haven’t been able to connect to my server via WebUI once. Thank you for your time and please help!

Update: I did a fresh install on a new laptop and now everything appears to be working fine, thanks for everyone’s help.

1 Like