Can't boot into OS after forced shut-off

So I had to force shutoff the server. I did not realize this would lead the problem I’m facing now.

I’m currently stuck with BusyBox initramfs. I’ve tried to run fsck /dev/mapper/turnkey-root along with -y, -yfv and -pfv arguments. Nothing, no dice. It would still give me WARNING: Filesystem still has errors. I’ve run it multiple times.

Then I read that going through a livecd would help. I used my Arch usb and tried doing that as well. I still have the same issues. If I try to fsck /dev/sda1 it says that it’s in use even though it’s not mounted or anything. Using ssh, I’ve tried a lot of different solutions that I’ve read online. The most I can offer is this screenshot about it. I still end up with /dev/mapper/turnkey-root: ********** WARNING: Filesystem still has errors **********

I’m trying to avoid reinstalling the OS. If it comes down to it, teaching me how to mount the disk to get the files off would be nice too.

One final detail that might help is that I’m using an SSD that is new. It’s never been used up until now.

Edit: I’ve gone through a lot of sources, but here are a few I’ve tried already: 1, 2, 3

When booted from a live distro is it possible that the mapping is no longer /dev/sda1?

Is this a virtual machine, or a physical machine? Your’e not saying anything about WHY you needed to force your server down. If it was a freeze error, it may be related, as for exampel an hard drive failure.

Your main error seems to be a write request error, which means that the system cant wirte to the disk. It may be a file system bug, but most of my googling falls down into one advice when fsck -f wont help:
If possible backup, then reinstall. You may need a new HD.

Har drives are comparatively cheapish today, so I would reccomend getting a new drive, reinstalling on that, then mounting the old drive and see if you can transfer data you need (like the minecraftservers) from the old to the new.

Sorry for the late reply. The force shut off was due to no response from the system. I normally wouldn’t do this, but I had no other choice at this point.

I had gotten a few new drives to try again, although I can’t seem to recover the data from the drive. I’ve tried using badblocks to see what was wrong with the drive although it returned no badblocks. I’m trying to mount the drive on Arch and can’t get passed
mount: /mnt: can't read superblock on /dev/mapper/turnkey-root.

I’ve tried using a few different methods that involve using vgchange and have not had any success. It doesn’t seem like the drive is bad. I’m totally stuck right now and haven’t moved from where I started.

Edit: I should add that lvscan returns ACTIVE for /dev/turnkey/root when trying to mount.

Try attaching to a different cable/ port/ machine and see if the results are different.

I have already tried that.

But I had asked around and found the solution. The solution is to mount the drive as readonly. Which is something I missed.

For anyone who might encounter the same problem and trying to recover their data but has failed every step along the way:

  1. vgscan Check to see what is being read. In my case it was only turnkey
  2. vgchange -ay Activates the logical volumes. If you have multiple make sure to specify at the end. So sudo vgchange -ay turnkey
  3. Run lvdisplay and verify the logical volumes are there and take note of the path you’re trying to get to. In this case LV Path /dev/turnkey/root
  4. sudo mount -o ro,noload /dev/turnkey/root /mnt to mount the drive. If the drive was healthy (like mine) it should mount fine.

Source for the first 3 steps

Thanks to everyone who helped :slight_smile:

1 Like