Can't access server on the internet


#1

So im running MineOS in vmware, bridged mode. Its been given it’s own ip, and connecting to the server through lan works fine, but not over the internet. I know port forwarding isnt the problem, as i tried changing the port forward to my host machine and setup a server within windows. And it worked as it should. Now i dont know much about this, im just kind off learing as i go, but my netstat -nat output shows that its listening for 25565 on tcp6, not on ipv4. Do you think this is the issue, or am i just stupid?

Also excuse my bad grammar, im not that fluent in english.89d254c034951a076d27e75e2dd68ce5


#2

Have you checked the iptables on your mineos server?
https://minecraft.codeemo.com/mineoswiki/index.php?title=Iptables


#4

Havent changes iptables at all since i did a fresh install.


#5

Then it is definitely port forwarding.


#6

I dont get how i’m doing it wrong, when if i just swap the ip on the forwarding to the host pc and i start a server there. It works fine


#7

Alright, I think the issue is that you’re putting in an address in the server-ip field of server.properties–this field should be left BLANK.

Basically, what’s happening is you’re telling Minecraft "only listen to requests to connect via the localhost, 127.0.0.1. On your desktop (where both your temporary server and your game client is), they are BOTH on localhost, and that’s why it works.

It doesn’t work when you’re connecting to your MineOS instances from 192.168.1.122 (presumably your desktop IP address), because a server won’t respect any requests not coming over the 127.0.0.1 interface.

Why things are showing up on TCP6 is beyond me, but let’s address that if it’s an issue. Right now, I really believe the issue is the server-ip field in server.properties.


#8

The thing is, connecting to the server from my desktop (192.168.1.122) works fine. Mineos is hosted on a separate windows machine running vmware.
Basically the only issue is over the interner, for example a friend joining thats not on the lan. You would think its port forwarding, but im 99% sure is isnt. My theory is vmware is causing some issues somehow, i cant seem to find a good answer on google


#9

Check the windows machine. As an experiment: Turn off the firewal on the windows machine running VMware. If your problem is then solved, we know where there is a problem.: You need to tell windows firewall to lett traffic through to your VMware and MineOS host. Do not leave the windows firewall off.

Your symptoms are routing or blocking related. Ths means port forwarding, or firewalling (either windows firewall, or iptables). We have checked your iptables on the MineOS host, so it’s not there. You are dead certain that it is not port forwarding. Then it is only the windows machine left.


#10

Hi,

Just trying to help out here though it’s worth confirming that your MineOS server can actually reach the internet ? If you were missing / mis configured your Default Gateway on your MineOS server then it would not be able to reply to a request coming from a different network ?

My first port of call is to rule out the obvious. You say that it works locally when a client is connecting on the LAN, so you wouldn’t really need / use your default gateway in this particular instance.

If your setting up port forwarding to a different machine then logic would state your ok with setting up port forwarding. I would then look to try and install ‘TCPDUMP’ on your MineOS server and see if your are receiving any requests from the internet.

As others have stated, it wouldn’t be remiss to rule out local machine firewalls so its worth turning this off.

Finally, you could perform a test and put your port group into Promiscuous Mode. It would rule out any Vlan policy issues that may or may not be present on a vSwitch.

Further info on that can be found here:

https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1002934

You could also try to telnet to see if that produces a response on your terminal as that will indicate whether your minecraft server is listening on the correct socket…

e.g - telnet x.x.x.x 25565

HTH

Matt