Cannot start MineOS on ubuntu


#1

I installed MineOS on my ubuntu server, Im sure I followed all steps correctly but Im getting “Job for mineos.service failed because the control process exited with error code . See “systemctl status mineos.service” and “journalctl -xe” for details.” every time I do “service start mineos” and WebUI is inaccessable


#2

What do your logs say: /var/log/mineos.log


#3

Here is the log:

{“level”:“info”,“message”:“Starting up server, using commit: 14b11c2 Merge pull request #234 from hexparrot/ftbinstall\n”,“timestamp”:“2017-03-01T09:28:07.214Z”}
{“level”:“info”,“message”:“Starting up server, using commit: 14b11c2 Merge pull request #234 from hexparrot/ftbinstall\n”,“timestamp”:“2017-03-01T09:55:16.776Z”}
{“level”:“info”,“message”:“Starting up server, using commit: 14b11c2 Merge pull request #234 from hexparrot/ftbinstall\n”,“timestamp”:“2017-03-01T11:12:06.964Z”}


#4

Ack, that is surprisingly thin, those logs.

Alright, since the webui is down, try this as root please and let me know what you get:

cd /usr/games/minecraft
chmod +x webui.js
./webui

This should attempt to start up the webui in the foreground, i.e., you’ll be able to see any errors that crop up that are happening (and evidently so early they’re not getting logged).


#5

Error while chmod webui.js, Got return message
“cannot access ‘webui.js’: No such file or directory”


#6

I tried to reinstall mineos using this tutorial https://minecraft.codeemo.com/mineoswiki/index.php?title=MineOS_(apt-get)

But still can’t find webui.js, I checked the repository my self and I didn’t see any webui.js


#7

Did I miss anything? Or should I follow the instructions on https://minecraft.codeemo.com/mineoswiki/index.php?title=MineOS-node_(apt-get)


#8

hi Riko_Edgar,

the first link you posted is indeed for installing MineOS on ubuntu.

however it is python based and comes with java 7. it has no webui.js.

the latest distribution in your second link, uses NodeJS and that would be why you need that one to have a webui.js.

so what to do?

well, the latest distro will install on ubuntu but is that wise? i don’t know.

i do know that it the nodejs version comes with turnkey pre installed. with it is a LAMP light or something equivalent based on jessie and java 8. that eliminates the need for ubuntu in my view. make the server a stand alone mc server by installing the bootable .iso and letting it reformat and utilize the whole disk.

if you require the server to do other things besides running minecraft and want the MineOS installed on top of ubuntu (i ended up rejecting this after i tried it years ago, for some reason) you may want to look at using a virtual machine like vmware.

that way you can run your mincraft server separate from your ubuntu server.

good luck!

tNt


#9

The latest distro installs just fine on ubuntu. But first you need to uninstall the python version.

This means deleting al mineos related files. and uninstalling thepackages that where installed using the python wiki.

Then you need to use the node wiki to install that version.

Oooor. You can shortcut it, and reinstal ubuntu first,then follow the node.wiki


#10

thanks for the suggestion :smiley: I’ll reinstall my server and reinstall mineos


#11

I took advice to reinstall my current OS (ubuntu 16.04) and followed all instructions on Node Wiki but I’m having trouble when executing command “supervisorctl reload” it returns error msg:
error: <class ‘socket.error’>, [Errno 2] No such file or directory: file: /usr/lib/python2.7/socket.py line: 228

I started the webui.js it works before stop again after 1 minute and print message “express deprecated res.sendfile: Use res.sendFile instead webui.js:179:13”

Here is my log file:
/var/log/mineos.log

{“level”:“info”,“message”:“Starting up server, using commit: 14b11c2 Merge pull request #234 from hexparrot/ftbinstall\n”,“timestamp”:“2017-03-02T11:55:50.522Z”}
{“level”:“info”,“message”:“Starting up server, using commit: 14b11c2 Merge pull request #234 from hexparrot/ftbinstall\n”,“timestamp”:“2017-03-02T12:00:47.434Z”}
{“date”:“Thu Mar 02 2017 07:01:00 GMT-0500 (EST)”,“process”:{“pid”:24354,“uid”:0,“gid”:0,“cwd”:"/usr/games/minecraft",“execPath”:"/usr/bin/nodejs",“version”:“v4.8.0”,“argv”:["/usr/bin/nodejs","/usr/games/minecraft/webui.js"],“memoryUsage”:{“rss”:57344000,“heapTotal”:42446432,“heapUsed”:22929896,“external”:1563378}},“os”:{“loadavg”:[1.75390625,1.318359375,1.22314453125],“uptime”:8289173},“trace”:[{“column”:15,“file”:“module.js”,“function”:“Function.Module._resolveFilename”,“line”:325,“method”:“Module._resolveFilename”,“native”:false},{“column”:25,“file”:“module.js”,“function”:“Function.Module._load”,“line”:276,“method”:“Module._load”,“native”:false},{“column”:17,“file”:“module.js”,“function”:“Module.require”,“line”:353,“method”:“require”,“native”:false},{“column”:17,“file”:“internal/module.js”,“function”:“require”,“line”:12,“method”:null,“native”:false},{“column”:18,“file”:"/usr/games/minecraft/server.js",“function”:"",“line”:229,“method”:null,“native”:false},{“column”:13,“file”:“events.js”,“function”:“emitOne”,“line”:77,“method”:null,“native”:false},{“column”:7,“file”:“events.js”,“function”:“Namespace.emit”,“line”:169,“method”:“emit”,“native”:false},{“column”:10,“file”:"/usr/games/minecraft/node_modules/socket.io/lib/namespace.js",“function”:“Namespace.emit”,“line”:206,“method”:“emit”,“native”:false},{“column”:14,“file”:"/usr/games/minecraft/node_modules/socket.io/lib/namespace.js",“function”:null,“line”:174,“method”:null,“native”:false},{“column”:9,“file”:“node.js”,“function”:“nextTickCallbackWith0Args”,“line”:489,“method”:null,“native”:false}],“stack”:[“Error: Cannot find module ‘userid’”," at Function.Module._resolveFilename (module.js:325:15)"," at Function.Module._load (module.js:276:25)"," at Module.require (module.js:353:17)"," at require (internal/module.js:12:17)"," at Namespace. (/usr/games/minecraft/server.js:229:18)"," at emitOne (events.js:77:13)"," at Namespace.emit (events.js:169:7)"," at Namespace.emit (/usr/games/minecraft/node_modules/socket.io/lib/namespace.js:206:10)"," at /usr/games/minecraft/node_modules/socket.io/lib/namespace.js:174:14"," at nextTickCallbackWith0Args (node.js:489:9)"],“level”:“error”,“message”:“uncaughtException: Cannot find module ‘userid’”,“timestamp”:“2017-03-02T12:01:00.153Z”}

Tell me if I did something wrong,


#12

also when I tried command “mineos” it print out error message" path.js:8
throw new TypeError('Path must be a string. Received ’ +
^

TypeError: Path must be a string. Received undefined
at assertPath (path.js:8:11)
at Object.posix.join (path.js:479:5)
at new mineos.mc (/usr/games/minecraft/mineos.js:128:15)
at Object. (/usr/games/minecraft/mineos_console.js:119:16)
at Module._compile (module.js:409:26)
at Object.Module._extensions…js (module.js:416:10)
at Module.load (module.js:343:32)
at Function.Module._load (module.js:300:12)
at Function.Module.runMain (module.js:441:10)
at startup (node.js:140:18)


#13

This is alarming because it seems like the supervisord package (unrelated, but used by MineOS) didn’t install properly?

This is saying it’s not finding the userid module in /usr/games/minecraft/node_modules/user_id, which is typically a result of not doing the (or not executing correctly) the npm install command.

Can you re-run the command (in /usr/games/minecraft as root) and let me know the results?