Cannot mod my Forge MineOS server because it sys I don’t have permission

I’ve tried many things that I’ve seen on here and none have worked. It looks to me like I need to sign in as root because it’s giving the Error code 3: No Permission.

What account are you using to log in?
I highly recommend not to use root as that could break the permissions in other areas.
Instead, I’d use sudo … if the account has been added to the sudo users list.

How do I do that? I’m very new to this kind of stuff.

You can either use root locally on the server, or PuTTY SSH on the mc account then use the su command to get root access.
Then enter the following:
usermod -aG sudo mc

Then, when you need admin permissions, you enter the command prefaced with sudo

you need to make sure to use the same user that runs MineOS to upload files, or a user in the same group as the “Group owner” on the server’s status page. Yes, you could use a root user to let you upload files, but then your files would be untouchable by the MineOS user, so you would be in a similar problem.

Usually, whatever username and password you’re connecting to the MineOS web ui with is the user you should use for WinSCP / FileZilla to upload your files.

Well, that’s unfortunate because the video I watched to set up the whole thing used a custom user for PuTTY and root for MineOS interface