Cannot login to WebUI


#1

Hello, I have a VPS where I installed Centos 7 64bit, used the wiki instructions to install MineOS, and I can get a web page (the WebUI) to login, but it does not let me login. I have tried with root and two other accounts I have created with no success. Does anyone know what could be the issue. Thanks!


#2

Can you log into the console either directly on the machine, or via SSH and putty?

You see the WebUI, but get error when trying to log in?

As MineOS relies on the underlying usermanagement of your OS, please check that the non-privileged user (not root) actually works by logging into the console either directly or via SSH/Putty.


#3

Hello, yes I can login to the console via putty. It’s weird actually, there are no error messages when trying to login, it just acts like the page re-freshed. I also can login as one of the non priviledged users too via putty.


#4


this is the login interface

Also, I just tried another browser to make sure that wasn’t the issue.


#5

Try restarting theWebUI by logging into the console:

Stop:
systemctl stop mineos

Start:
systemctl start mineos


#6

Same results :frowning:


#7

What do the MineOS log say?

/var/log/mineos.log

You should see your tries to log in there. Or other MineOS errors


#8

mineos.log

{“level”:“info”,“message”:“Starting up server, using commit: 50e3f4c updated dockerfile for stretch/nodev8\n”,“timestamp”:“2018-06-12T09:59:06.006Z”}
{“level”:“info”,“message”:“Starting up server, using commit: 50e3f4c updated dockerfile for stretch/nodev8\n”,“timestamp”:“2018-06-12T10:55:54.060Z”}
{“level”:“info”,“message”:“Starting up server, using commit: 50e3f4c updated dockerfile for stretch/nodev8\n”,“timestamp”:“2018-06-12T11:49:26.766Z”}

mineos.auth.log
Tue Jun 12 2018 07:50:14 GMT-0400 (EDT) - failure from: IPADDRESS user: USERNAME


#9

Is there access that needs to be given to the user? like executable to the mineos directory?

I appreciate you trying to help.


#10

Do your username or password use any special characters? It may be a charset error in the WebUI that translates a character wrong.

Please try to change password to something using only letters and numbers (just to check if that is the case, you can change back if you want to afterwords). You can do so using the command passwd after logging into the console


#11

I changed the username/password to test/password and get the same failure log from the mineos.auth.log file.


#12

Then I am starting to run out of Ideas. @hexparrot may be able to help?


#13

Thanks again! I may try another version of OS, I would just use turnkey, but I dont have an option to install an OS that is not listed on VPS.


#14

I have installed another distro based on Debian and now have access to the webui, Thanks so much @iMelsom for your time and help!


#15

@hexparrot:
Since this was resolved by workaround (installing another distro), the underlying error was not discovered. Out of curiosity (and to be able to give a better answer than “install another distro” to other users in the future), do you have any idea what was happening?


#16

I’d run into this issue before–and troubleshooted it a bit, but didn’t have the access or opportunity to find out the root cause, either.

See here: Problem loggin in on CentOS 7

It was an identical issue for auth, but basically CentOS must handle PAM modules or such differently, that nodejs can’t tap into it. It’s my best guess that CentOS is locking it down better (and perhaps not SELinux like I posited) and the issue lies in the PAM module config: https://www.centos.org/docs/5/html/Deployment_Guide-en-US/ch-pam.html


#17

No unfortunately. Im still having some issues, but I do not know, the logs just show login failure. I think maybe to do with security on the version of linux. It has been prob 10 years since I have worked on any linux servers and I am rusty to be honest.


#18

Well, just as in the linked page, this is how we would systematically find out what’s causing the problem: Problem loggin in on CentOS 7

The script itself tests 3 separate authentication methods, individually. If any of the three pass, the auth of MineOS will work by choosing that method.

Here’s a quick link to the script itself: https://pastebin.com/EaTLwkmv

The only requirement to this script is changing the first few lines to match a valid, existing non-root user. Currently it’s mc and password, but that can be changed to literally whatever login you’re using (and should be changed).


I think one of the core problems here is that all the CentOS related issues are docker builds or third-party images, as well, which mean there is config occurring AFTER the fresh install, which is what I’m testing.

If you guys can fill me in on what docker image file (or provide the build file to me)–or provide any way I can work on that type of system first-hand, I can use that and troubleshoot it more surgically!