Cannot create servers, import servers, accept eula


#1

i can get the webui to show up, but once logged in, i cannot accept eula, create servers or import servers, this is a fresh install of ubuntu 16.04 and mineos, any attempts to reset the webui also ends in systemctl error 203 i have tried and tried to work around it, but i cannot seem to get anything to work, i checked for updates for the webui and reset the scripts, but to no avail any help would be appreciated


#2

What are the contents of the logfile for MineOS. You can find it at /var/log/mineos.log


#3

the file is too large for hastebin or pastebin, can i provide a link to a google drive?


#4

the file is at
mineos.log


#5

Do the following commands:

cd /usr/games/minecraft
npm install

Based on your log, I see "uncaughtException: Cannot find module '/usr/games/minecraft/node_modules/userid/build/Debug/userid.node'"

There’s a module you need that doesn’t appear to be present in your installation. It’s definitely supposed to install, but for whatever reason it isn’t npm install will try to install it again. Verify (and share if possible) the results. It could be there are errors and no notice was taken of it.

BUT MORE IMPORTANTLY:

You shouldn’t ever have files that aren’t .zip or .tgz or .tar.gz in your /var/games/minecraft/import directory.

That is DEFINITELY causing a problem. That’s not where your servers belong, and the server there (or the files there, at least, have a TON of constantly growing log files creating zip files.

Move all files out of there immediately.