Cannot connect with port 25572 but can connect with 25565


#1

hi, I have a problem with logging into my server, I changed the port in the server properties file as well as opened 25572 within iptables. I can connect on 25565 after I change the port within the file but I cannot with 25572. I have updated as much as I could when it comes to webui and dependencies and such. even if I open up all ports on iptables it doesn’t work. I have direct access through my home firewall as well as added ports 25565-25574 to my desktop’s firewall so there should be no networking issues on my part.
I appreciate any help and thanks for an awesome OS.


#2

What do your logs say?
Taking a look at the minecraft logs will tel you if your game is actually starting up listening to your new port, or if there are some other problem.


#3

just took a good look at logs, its binding to port fine and the only errors I’m getting is plugin errors which wouldn’t cause it because i could join just fine before i switched the ports

Edit: made this for you to take a look if you need to
https://pastebin.com/D0YZGS0B


#4

I concur,
Your logs seems to tel me you are listening on you r deisgnated port:

[22:35:38] [Server thread/INFO]: Starting Minecraft server on *:25572

This means your server is sstarting up and assigninging a listener on the requirded port. This is important because it means your problem is smoewhere between your ruinning server, and the client you are trying to connect.

This is, how ever, quite a large wag between client and server.

May I have your minecraft server adderss? I do not need whitelisting or actual access, but I need to test what my client states when trying to connect to your sever.


#5

96.84.219.107
this is mostly filler but info, we have a custom ip through a business if you want to try that its
CrypticNetwork.tk


#6

Ok.

Tried to add server at 96.84.219.107 with both standard minecraft port, and your wanted port, but got no connection.

I will admit that I wa hoping this was a quick fix, but unffortunately Ihave to go to bed now.

Status so far:

You server states that it is listening to port : 25572

I tried to connect a standard minecraft client at port 25572, and at the default 25565 witout any luck.

This tells me (so far) that there is an issue between my client and you server somwwhere. There is at leas one IP-hop that is not passing on the required adress…

Let me break this down to the possible hops:

  1. .From your MineOS server to your Minecraft server
  2. From your internet gateway to your MineOS server
  3. From my internet gateway to your internet gateway.
  4. from my client to my internet gateway.

4: I know I have connection from my client to my internet gateway since I can reply to you here…
3: Black magig happening here… (or close to…)

1: your logs say your minecraft server is listening…

My conclusion:
There seems to be a connection error between your gateay and your server on the port you want to use.


#7

whenever you see this, any fixes/workarounds?


#8

Did you try rebooting after changing your iptables. it should be enought to reload them, but computers being computers, a rebbot often fixes things that should happen without a reboot


#9

yea I have rebooted I rebooted after I tried changing iptables and I gave the iptables fix another shot which didn’t work so I just rebooted again and left it as is. at this point, I kinda wanna use Ubuntu and get the webui service through apt-get as seen here
https://minecraft.codeemo.com/mineoswiki/index.php?title=MineOS_(apt-get)
of course, only after backing up the servers, that way I can start from scratch even though my server build isn’t that old, I built it around Christmas.
I’m currently using MineOS turnkey from the download off the wiki
im very familiar with Ubuntu as I am currently studying to be a Linux administrator and Ubuntu Server 18.04 LTS is what we use.
What are your thoughts?

yep, edits. last one, I’m just going to switch to Ubuntu because I was just on my personal server on 25565 and I had left because the connection was going weird and now I can’t connect at all, I can’t even ssh into it so, ** I appreciate the help**. I’m sure the install was just bad because me and the co-owner had a bumpy ride. it worked great on my 1st machine which is now running a different OS and different setup but things are really slow with this one. wish me luck.

edit 329184, thanks for the help, got it on ubuntu