Can start server from CLI but not from Web-UI

I can cd into the server directory and start it with
However if I click start on the web-ui (I have the correct ftb jar selected) it will say Up for about a minute or two RAM usage getting to about 4.1-4.2 which is typical for freshly started FTB server in my experience then just go down.

Details about my setup:
VM running under ESXi with 12GB RAM, 16 cores. It’s a FTB Infinity Server 2.6.0 (1.7.10). This is a fresh VM and using an archived server to create a new server.

/var/log/mineos.log -
{“level”:“info”,“message”:"[WEBUI] New file found in import directory /var/games /minecraft/import/server-FTB01_2017-12-14_12_40_44.tgz",“timestamp”:“2016-12-04T 03:53:43.833Z”}
{“level”:“info”,“message”:“Starting up server, using commit: 37e4a9d fixed issue : profiles broke with mianite xml change\n”,“timestamp”:“2016-12-04T03:53:43.955 Z”}
{“level”:“info”,“message”:"[FTB] eula.txt detected: ACCEPTED (eula=true)",“times tamp”:“2016-12-04T03:53:45.189Z”}
{“level”:“info”,“message”:"[FTB] autostart = false",“timestamp”:“2016-12-04T03:5 3:48.604Z”}
{“level”:“error”,“message”:"[FTB] Aborted server startup; condition not met: tru e",“timestamp”:“2016-12-04T03:53:48.604Z”}
{“level”:“info”,“message”:"[WEBUI] mc connected from",“timestamp”:" 2016-12-04T03:53:56.156Z"}
{“level”:“info”,“message”:"[WEBUI] Downloading official profiles.",“timestamp”:" 2016-12-04T03:53:56.416Z"}
{“level”:“info”,“message”:"[FTB] mc ( joined server namespace",“tim estamp”:“2016-12-04T03:53:56.627Z”}

I think this is where it is but not sure what to do with this.
{“level”:“error”,“message”:"[FTB] Aborted server startup; condition not met: tru e",“timestamp”:“2016-12-04T03:53:48.604Z”}


That error points to the line above:
FTB] autostart = false",
When discovering and loading your server files, Mineos checks to see if the autostart variable is set to true. If it finds it to be false, it aborts staring the server ehen MineOs starts. It has nothing to do with why your server stops after you click the start button.

Is that the entire contents of the mineos.log? Or just the parts you think are important. Usually we need the entire contents, since errors might hide elsewhere and seem uniportant.

We also need the following logs:
/var/games/minecraft/“name of your server”/logs/latest.log
/var/games/minecraft/“name of your server”/logs/fml-server-latest.log

Those two are the log for your minecraft server, and the FTB spesific log.

Since you are able to start using CLI, and not WebUI, it may be an WebUI issue. Have you tried updating the WebUI?

1 Like

All three log files: some was really long so put them on my webserver rather then pasting.
Did update the web-ui and tried again, nothing.


Please make sure you have chosen a valid jar file in the WebUI control panel for you

You have several of this error in your log:
{“level”:“info”,“message”:"[FTB] received request “start”",“timestamp”:“2016-12-04T02:49:03.618Z”}
{“command”:“start”,“uuid”:“3773c620-b9cc-11e6-a8d2-b1bbceb50be1”,“time_initiated”:1480819743618,“success”:false,“err”:“Cannot start server without a designated jar/phar.”,“time_resolved”:1480819743742,“level”:“error”,“message”:"[FTB] command “start” errored out:",“timestamp”:“2016-12-04T02:49:03.743Z”}

The “Cannot start server without a designated jar/phar.” error only comes if you try to start the server without a jar selected.

It may also be that you need to select a different jar in MineOS than you run from CLI. Both jars should be in the same directory

It’s not that, because this doesn’t use a profile and you can make custom ones now, you just put the jar’s in the live server directory, however the web-ui doesn’t pick them up until you log out and back in (what I found out), so that error was me trying to start the server when the web-ui didn’t pick them up. I have tried with the FTBServer-1.7.10-1614.jar and the FTBserver.jar neither work.

Got it working, I switched to root and run: chown -R mc:mc /var/games/minecraft/servers/FTB/
Now it starts properly via web-ui. Thanks.