Can not read and write files on turenas Scale

So I am running a minecraft server over turenas Scale for me and my friends. Everthing works fine however I can not read or write files in the Server directory. I have tried giveing my user somb over the Unix Permissions Editor permission to the dataset (with enabling Apply permissions recursively), however when I do that the server diseapears from the mineos Web Ui but I can read and write the files. The dataset is set to smb.
Sorry if I left out any important information or if my explanation does not make sense. I am pretty new to al this. So Thank you in advanced.

I suspect your’e doing the oposite of what you need to do.

In stead of moving ownership and such to your user, you need to give your user group access to the relevant files and folders. I suggest making a new group for managing MineOS wervers, then making both your user and root group membership. Then set everything to read, write and run for that group. Let root stay as owner.

Please read for more on managing users and groups in linux.

Hey! I ran into this issue yesterday, and here’s the solution I made.

First and foremost, you’ll want to create a dataset in your pool (I created a folder in an existing SMB share) and make sure that the user has full access to said dataset through the ACL.

After that, I set the host path for the MineOS docker to the new dataset I created, and the SMB share worked perfectly.

As for things not showing up in the server list, I found that restarting the app a couple times fixed the issue, and giving it a bit of time to boot before jumping into the web portal helped a bunch. That said, if you need a better explanation of setting up a dataset and ACL rules, you’ll have better luck on the Truenas forums, as opposed to here.