Bukkit is down now

Hello all.

As some of you know, Bukkit died :frowning:
And hexparrot, you can remove the Bukkit profiles to make more clean if you want.

And hexparrot, you can remove the Bukkit profiles to make more clean if you want.

That might be a premature request as Mojang has publicly committed to helping to restaff Bukkit. That said, who knows if that’ll work and the community will get behind those efforts.

If Bukkit does go, I think that there will be something to take its place. The Modding community is still strong.


But there is already a new project :smiley:


1 Like

It looks like it might still be a while before they’re able to release something (based on their FAQ tone). They are aiming for 1.8 (“or whatever 1.8.x version exists at the time.”) so I’m guessing they have a bit of work ahead and a lot of conversions plugin authors need to learn and make…but I’ll be keeping an eye out!

1 Like

Just because it got canceled doesn’t mean the world stopped using it. Look how many servers out there still run MC 1.6 and 1.6. The profile should stay until the demand to use it does away.

But the preconfigured profiles for Bukkit are no longer functional because the official download is down.

1 Like

As Leeo97one said, there is now sponge available, however it is only available as an API, not as a server-usable jar. I was wondering if there is another project available that is complete and has bukkit plugin support.

I have now been looking for some time and would appreciate it,

Thanks in advance,


Spigot is updated to 1.8 with support of most bukkit plugins. (Craftbukkit and Bukkit are updated by Spigot team too.) Unofficially built jars download can be found here, you can check md5’s to be sure there is no malware.
Also there is a project named Rainbow with limited plugins support, but with it’s own unique features. Also full support of 1.8.

Thanks for those options. I have installed rainbow and it looks… interesting. I have tried to use spigot, but I encountered an error, my log from BuildTools.log.txt is pasted here:

Git name not set, setting it to default value.
Exception in thread “main” java.lang.RuntimeException: Error running command, return status !=0: [git, config, --global, user.name, BuildTools]
at org.spigotmc.builder.Builder.runProcess(Builder.java:393)
at org.spigotmc.builder.Builder.main(Builder.java:107)
error: could not lock config file //.gitconfig: Permission denied

Wondering if there is a fix for this.

Once again, thanks in advance

Permission denied. Check your file permissions are the same as your user that is trying to run it.

I did check, and mc had permission to execute “BuildTools.jar”. The same error still showing up. Something I didn’t mension in my previous post: this error was shown in “BuildTools.log.txt”
List of files in directory of my server:

I second this. Are you sure you hadn’t (inadvertently) run any commands as a more privileged user previously, such as root?

.gitconfig is a hidden file, one which is absent from your provided file list. If you had, for example, run this previously as root, .gitconfig is probably owned by root. Then, you may have deleted the files in the folder (at least the ones you saw) and thought you had a fresh start.

Alternatively, you could just be running this in a directory your current user simply doesn’t have access to.

Show us ls -la for the directory you’re trying it in, like this:

mc@core ~/zz$ whoami
mc@core ~/zz$ ls -la
total 2976
drwxr-xr-x 4 mc mc    4096 Dec 15 22:18 .
drwxr-xr-x 9 mc mc    4096 Dec 15 22:18 ..
-rw-r--r-- 1 mc mc 3024587 Dec 13 23:29 BuildTools.jar

Here’s what I got when I tried this from a known-clean directory with no previous attempts:

mc@core ~/zz$ java -jar BuildTools.jar
Git name not set, setting it to default value.
Git email not set, setting it to default value.
Starting clone of https://hub.spigotmc.org/stash/scm/spigot/bukkit.git to Bukkit

From ls -la I got this:

total 2976
drwxrwxr-x  2 mc   mc      4096 Dec 15 22:25 .
drwxr-xr-x 12 root root    4096 Dec 15 22:25 ..
-rw-rw-r--  1 mc   mc   3024587 Dec 13 23:29 BuildTools.jar
-rw-rw-r--  1 mc   mc       375 Dec 15 22:25 BuildTools.log.txt
-rw-rw-r--  1 mc   mc       167 Dec 15 22:25 server.config
-rw-rw-r--  1 mc   mc       189 Dec 15 22:25 server.properties

I believe the line:

drwxr-xr-x 12 root root    4096 Dec 15 22:25 ..

may be the issue, but how do I change permissions from root to mc?

Never mind, I was starting it with the webui instead of the command, seems to have gotten files now, so that works.
I think I know what to do now, thanks for all the help.