Big problem forge

Hello I installed mine os on truenas and I had no problem launching a vanilla version but against Forge it’s been 3 days since I’ve been disappointed without any evolution I can’t even launch it impossible he doesn’t want to know anything.
Do you have any technical advice on this subject?
Thank you in advance and good day!

Sad to hear you experience problems.
If vanilla works as it should, there are no problems in your MineOS installation. There may however be other dependencies that are not met for running forge on your installation. Most likely it is a Java problem, as the different minecraft server version have different java dependencies. your best bet is to check the MineOS logs to se if any errors reveal them selves there. As the next step in you should SSH into your MineOS installation to try to start a Forge server manually thorug command line to see if it shows any errors, or where starting the server fails. You can also search this forum for “Forge”. There are several others that have had problems, one of them may have a problem similiar to yours, and a solution most likely is allready written there

I am afraid that witout access to logs, or precises steps of what you have or have not done it is difficult to be any more spesific.

thank you for your answer and I looked at it would come from a possible error launching Java which will not be able to “read” Forge but I am new to true nas and I do not see how to access the problem and either how change the forge version. If ever the version I want to install is 1.12.2
thank you for your help

I have no knowledge of Freenas because i have never used it but it seems like it causes a lot of problems and Mineos is hard to run on it as i see people with problems about it often on other websites.
I would say remove Truenas from the equation but that is just my opinion at the end of the day and its not valid. I am not really sure why people use it as there is better options. From what i can tell Freenas looks better suited at what it does best and that is storage and cloud storage.

it has become a bit of a swiss army knife from what i can tell and its not very good one for Minecraft i could be wrong again i have never used it but i just see people always having problems with MineOS on it, if you want that sort of intermediate layer then you should just use a more suited vm hypervisor solution something like not explicitly but think VMware or the several other free solutions that are available.

You can disregard this just my 2 cents

I guess seeing as you said that a vanilla version works fine but a forge version does not then are you sure if you installed forge correctly?

What version of Minecraft are trying to run? and what forge version?

thank you for your answer all vanilla versions work correctly forge “1.12.2 latest” does not work but i am not sure how to install forge i guess to do it correctly. in fact freenas is the old version of truenas “freenas” no longer exists I use true nas because it allows to have a nas with different plugins including mine os but I agree it brings more problems

Sorry my bad was a typo meant Truenas not Freenas, after looking on Truenas this post seems pretty relevant

The person is also mentioning that ownership is envolved so this could be your issue check that mcserver:mcserver can actually run the ftb jar file or who ever is relevant can run it etc. Without much context to go from and because i myself have limited understand of truenas its anyone’s guess but that post looks like it is relaying the needed steps to run through.

It doesn’t work but I admit I had hope

After hours of research nothing has moved forward I am at an impasse I will try to explain my situation clearly I am truenas core I wanted to install mine os no problem on this point after that I tried a vanilla version which works well but I wanted to play with a forge version from that moment I consider the sucide as a valid option, nothing works nor the imports of server either the creation of server in short if you have a solution I’m interested

What does this mean exactly? How are you trying to install forge?

You are trying to install from here?

Yes I try from here but without any result on any version
even by doing a server import it remains blocked
mine os start

That is the installer that you have selected so run that once and it generates the jar file that you need so if it works properly it will say a message in the console and then you should have the new jar file which is the one you need to use to run the server.

Yes the forge1.12.2 file but when I run it it doesn’t work
hand against minecraft server 1.12.2 file when i run it works fine

it will be called forge-1.12.2-universial or something along those line or maybe without universal but it wont say installer.

ok you will need to check the mineos log like Melsom mentioned did you check it?

No, how do we
and I launch with the version forge universal but it does not work

The problem is that the server file you try to start is an installer.
I downloaded it, and it wont start here either. Starting it manually gives the following error:

java -jar forge-1.12.2-
JVM info: Oracle Corporation - 17.0.1 - 17.0.1+12-LTS-39
Found java version 17.0.1
Exception in thread "main"
No X11 DISPLAY variable was set,
but this program performed an operation which requires it.
        at java.desktop/java.awt.GraphicsEnvironment.checkHeadless(
        at java.desktop/java.awt.Window.<init>(
        at java.desktop/java.awt.Frame.<init>(
        at java.desktop/java.awt.Frame.<init>(
        at java.desktop/javax.swing.SwingUtilities$SharedOwnerFrame.<init>(
        at java.desktop/javax.swing.SwingUtilities.getSharedOwnerFrame(
        at java.desktop/javax.swing.JOptionPane.getRootFrame(
        at java.desktop/javax.swing.JOptionPane.showOptionDialog(
        at java.desktop/javax.swing.JOptionPane.showMessageDialog(
        at java.desktop/javax.swing.JOptionPane.showMessageDialog(
        at net.minecraftforge.installer.SimpleInstaller.launchGui(
        at net.minecraftforge.installer.SimpleInstaller.main(

Searching Google for “forge installer headless”

led me to this page:

So it seems at first run you need to run withfollowing in the field “Additional Jar arguments:” --installServer

The server will then stop again, but a new jar has been made. You need to select that one instead (the one without “installer” in it’s name)
Remember to remove the --installServer argument before you start the server again

Now it fails for me as I probably have the wrong java version for forge .1.12

1 Like

yeap that is key lol i totally forgot about that but this is your problem.

This was initially on the old wiki and should be on the new wiki too but i couldn’t find anything like this on the new one.

The logs are also kept at /var/log/mineos.log which you need to know and can read its something you should read sometimes if you have problems it depends really because its not a catch all but it can be helpful.