Authentication servers are down ... network not setup right?

Hi all,

I am working with ubuntu server 18.04.3 LTS and installing what i think is MineOS turnkey ontop. using the MineOS-node (apt-get+systemd) guide on the wiki, along with the iptables guide to add the rules as well as add a second port to host a double server. (one for a group of friends and one for my family). everything installed correctly and the process was pretty simple up until i tried to download a profile through the webui. none would show up so i downloaded the jar from mojang and put it in the server files in using the ssh. i then was able to get the servers up according to the webui. i made sure the port fowarding is correct according the to TheBreakdown guide for port forwarding. but now when i try to log on the first server which uses the default port for minecraft 25565 with my public ip. i get the error “Authentication servers are down” from the minecraft launcher. and the second server is the same way. following a forum problem i tired pinging to see if i setup my connection right. and through the ssh i got " ping: Temporary failure in name resolution " as the servers answer.

im a pretty big noob when it comes to ubuntu so any suggestions would be a huge help.

Thanks all

Your DNS (‘domain name server’) isn’t correct on the host. It could very well be that your server can see your local network, but your gateway address is incorrect. Your gateway is used when you request an address not on your local network.

That might explain why you can use the console/SFTP/see the webui. All those are on the same network, but google and the Mojang auth servers are not, so they get passed to your gateway, which is evidently not set up properly. Once you can ping google, you can have confidence things are working as they should; even the profiles should start appearing.

thanks for the quick response,

So what would be the best way to check the gateway ? and if it is wrong (probably is) correct it ? as i am not quite sure what i am looking for.

thank you for the help.

So you’re using Ubuntu server and you’re just installing the MineOS webui (not turnkey).

That means that all instructions and tutorials for setting up your network for Ubuntu would be relevant here. The information you’d use typically aligns with your ‘gateway’ referring to the IP address of your home router.

Hey all I just wanted to give an update and mark this as fixed.

I’m not sure how i did it, but i fixed it. I’ll list out event that transpired and maybe someone might know how it fixed.

i found out after trying to reboot that the hardware wouldn’t boot up the drive i have the server on. even after disconnecting all other drives with only this one to boot it still wouldnt boot. i followed some googling that led no where and reset the bios of the machine to default settings. and after enabling setting for legacy (so i could see the drive) and changing nothing else in the bios setting the server booted from the drive. i then was also able to ping google from the server and the now runs as intended. i can access profiles and join both servers.

sorry that i can’t explain this fix. Im honestly not sure why it worked. but my guess would be that the act of rebooting the server caused whatever held up in the network to fix itself. (turning it off and on again saves the day).

If anyone has a better explanation would love to hear it.

Thanks all

1 Like