Authentication error for vanilla 1.8

I just setup MineOS using the pre-packaged Turnkey bundle on a bare metal system and decided to test it with a new vanilla 1.8 world. It worked at first, but after running for a few hours the system disconnected and kick me off the server. Any attempt to reconnect give the message: “Authentication servers are down, try again later.”

From what I can tell this means that the server can’t verify my user ID with Mojang’s servers for some reason. I checked and there are no disruptions on Mojang’s servers, so something on my system must be blocking access to the authentication server. I tried disabling online-mode and I was able to connect no problem. Im thinking this is an error in the firewall configuration but I dont know how or where to start with that. I have already verified that my router is not blocking access to Mojang’s servers so it must be within my system configurations somewhere.

What confuses me is why it worked at first and then quit seemingly at random. Any thoughts on what is causing this and how to fix it? thanks in advance for any assistance

If you get the message “Authentication servers are down”, it simply means they are down.

It’s analogous to if you tried logging into your email and got “our email servers are temporarily down” vs “Chrome could not make the connection to this webserver”–the message is coming from the correct, intended place, but they simply (and for reasons unknown) weren’t able to authenticate.

The fact that it had worked at first means that it is not a firewall or router configuration issue; the simpler explanation is usually the correct one.

But i checked and Mojang’s servers are fine, and i can log into other servers no problem, so how then is the authentication system not working for my system? ive tried waiting a day or so and the same error comes up. could it be something with EULA or something like that?

Try changing your Server Property Online Mode to false and restart the server.

I tried that and it then works fine but it then of course it doesn’t use the user’s skins and saves their inventories separately from users who logged in while online-mode was set to true

Authentication doesn’t happen on your Minecraft server. The process goes like this:

  1. Authenticate at the Mojang (creators of Minecraft) server with username and password
  2. Retrieve a session id
  3. Contact the server you want to play on and send your username and session id (for verification that you own tat name)
  4. Send every 5 minutes a keep-alive request to the Mojang server so that the id does not timeout

Authentication is the sending of your username and password to Mojang servers at step #1. Provided all goes well, they return an authentication token back to your client (on your desktop) that verifies this.

Your client (desktop) then contacts your server (mineos) and says “I am this player–let me log in”. The server checks the value online-mode and if true, says “yeah, well show me your auth token”. Your client provides the token, and you are logged in.

If the online-mode is false, your client contacts your server and says “I am this player–let me log in” and the server says “sure, I believe it” and that’s that.

In receiving the error after trying to connect to your server (mineos), this is aligned with the idea that the Minecraft jar (the server) has connectivity to your desktop. If you want to remove the firewall, you can, though I doubt it would fix the issue.

At any rate, in the past few hours there have been a few tweets with your same symptoms:

It’s not surprising that for intermittent issues (read: a problem a few people are having, so they assume ‘all is well’ and ‘the problem must be on your end’), but for these people–like you–it is less likely that non-existent changes to your own firewall config is going to work one moment, and stop the next.

Furthermore, these people are not likely using MineOS, which corroborates the idea it’s authentication-server based, rather than your own config/server.

1 Like

ahhh okay I see, thanks for the explanation. so i guess all i can do is just wait till mojang does something about it then?

I remember having trouble with this on mineOS.

The problem was that the serverclock was wrong and that somehow affected the authentification. I think the server says to the client “I don’t belive you! That authfication token is to old.”

The resulution was to set the clock to current time.


wow do I feel dumb, this was what was wrong, the system thought it was the year 2022, guess i forgot to check the time settings in the BIOS, works fine now. Thanks guys!

1 Like

I am happy to help. :slight_smile:

1 Like

Ah, that’s an amazing catch…thank you for letting us know about this!

1 Like

The fact that you can actually help and get appreciation for that is very rewarding and good for your self esteem. Thank you.


Off to fix my server clock. :smile:

1 Like

:expressionless: My server clock was only off by five hours, and it still won’t connect.
I guess it thought I was at GMT 00:00 time or something. I’m actually
at GMT +05:00. Regardless… I’m still pretty stuck. Help?

Just to make sure you have it as perfect as it can be, here is the official Turnkey page on configuring the timezone (and recommends keeping your hardware clock at UTC!)

1 Like

ahhhh, but now it won’t connect to the internet! (It won’t download update packages). I typed in apt-get update, and it sat for a bit and spat out a bunch of "error: could not connect"s and stuff.

Here’s what I got after trying your advice:

Installing package(s) with command apt-get -y --force-yes -f install webmin-time …
Reading package lists…
Building dependency tree…
Reading state information…
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 18 not upgraded.
Need to get 67.4 kB of archives.
After this operation, 92.2 kB of additional disk space will be used.
Err wheezy/main webmin-time amd64 1.630-turnkey+0
Could not resolve ‘
Failed to fetch Could not resolve ‘
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

… install failed!

EDIT: installed it by downloading the .deb and using the package upload feature.

Based on that error, I think we can safely deduce it’s a connectivity issue at a much higher level. Your other problem with authentication server is down seems to be explained perfectly by lack of connectivity.

I suspect you’ll find pings are also not working, so that is what we’d need to address.

Are you connected wirelessly or by wires?

When you boot up the server (and you can reboot it if you need to), does the prompt at the start say you’ve been issued an IP address?

(side note, don’t worry about the timezone now anymore, that seems to be a non-issue here. If you are interested in setting the timezone all the same, this blue screen from boot-up is a better alternative than the apt-get method–it’s described at the bottom of the linked page).

Um, let me check the ping… thing. (sorry, it rhymed, couldn’t help it)

The server is wired into the router.

I told the server to take a specific address. When it boots up, at the blue configuration console screen, it says I have an IP address that is, and I can fill in those x’s for you if you need them. I told it to take the address at, though, so it makes sense it would take that one.

Do I need to change this in order to get my server working? I thought that was sort of against the whole concept of port forwarding.

Also, I was able to connect to it with the webmin and WebUI.

When you have addresses with 192.x.x.x, they’re “private”, but they need not be secret; there’s no harm in showing them.

With the loss/lack of connectivity, but you’re telling me you’re using a static IP, here is my recommendation:

  1. Turn off static IP. Let your router allocate the IP address it wants. Yes, I know you’d want it static in the end, but right now, setting up the static might be the reason for lack of operability.
  2. Test your pinging after you’re using DHCP
  3. Explore if your router has static routes or ‘static dhcp’–it is the preferred equivalent of you getting an IP address issued dynamically but with the added bonus that the address never changes, and therefore will be suitable when you want to make your server accessible to the world.

All of this can be done from the blue screen that pops up from restarting your host system. Restart from there as well is probably the easiest way.