Archive errors out, backups work fine

I’m running MineOS in a Docker container on unRAID.

I have an archive set to run every hour (0 5 * * * *), but each time I get:

{"command":"backup","source":"0 5 * * * *","msg":"","enabled":true,"success":false,"err":1,"time_resolved":1590435540962,"level":"error","message":"[testingathingtesting] command \"backup\" errored out:","timestamp":"2020-05-25T19:39:00.962Z"}

I tried giving 777 permissions to the archive directory, no dice.
All dirs are “richard:1000” as created by MineOS by default under unRAID.

Anyone have any other ideas of what might be causing this?

Where do you have that command set? Can you post the command you set?

It’s just a ‘backup’ command from the scheduling section of the webUI.

I created a new world, logged in, logged out, scheduled the backup for a couple of minutes past the current time, and got the same error as above.

I’m on mobile or if post a screenshot, but I can get one tomorrow.

I find I’ll have a harder time troubleshooting this, because I am entirely unfamiliar with unRAID, but the first thing to check is not whether we’re referring to the same thing.

You say you have an archive set to run every hour, but your command output clearly shows ‘backup’, rather than archive.

So a few questions:

  1. are we concerned about ‘archive’ erroring out? If so, what is the log entry suggesting the archive is failing?

  2. have you made other blanket changes to the filesystem with chown or chmod (what you did 777 with)?

  3. aside from the cron, does making a backup or archive succeed. it’s the exact same process. I’m compelled to believe that if the cron is failing, so would a direct command. Test whether or not the command–separate from the cron–works as expected and report back.

Understood. I’ll do what I can to remove variables from the unRAID side. The most I’ve done is to change folder perms or ownership, but they’ve been set back to default at this point.

  1. It actually varies from server to server, which may have been the source of the confusion. There are two main ones. On one, the archive functionality was broken, but backups worked. On the other the behaviour was the opposite.

  2. I changed ownership to root:root, and tried mc:mc, but as that user didn’t exist in unRAID, that obviously failed. I set everything back to richard:1000 as created by the container.

  3. Correct. Manual triggers show exactly the same behaviour as the cron jobs I was triggering. (a couple of minutes ahead of current time).

At this point, I’ve manually triggered archives and backups on both servers again to test, and only 1 is failing. Backup on the second server. The third test server I made that previously failed on both, now passes on both.

Since posting originally, I’ve changed nothing. The only thing that’s happened in between is that Minecraft server (corona_gaming) got restarted once or twice. The third test server? Absolutely nothing.

The cron I’m using, just for completeness is:
0 5 * * * *
With the intent of triggering at 5 minutes past every o’clock.

From the logs:
{"level":"info","message":"[corona_gaming] 192.168.1.11 issued command : \"backup\"","timestamp":"2020-05-29T21:32:51.264Z"}
{"level":"info","message":"[corona_gaming] received request \"backup\"","timestamp":"2020-05-29T21:32:51.264Z"}
{"command":"backup","uuid":"f2e80c00-a1f3-11ea-a7d5-77dd68da2b5f","time_initiated":1590787971264,"success":false,"err":1,"time_resolved":1590787971343,"level":"error","message":"[corona_gaming] command \"backup\" errored out:","timestamp":"2020-05-29T21:32:51.343Z"}

It doesn’t seem like the error gives any specific information on why the backup failed, unless I’m missing something.

So, some updates on this.

  1. “Backup” is working on all servers except one, both scheduled and manual.
  2. “Archive with commit” is working on all servers, but only manually.

So first, the one server with restore point problems:
One server (corona_gaming) doesn’t do “Backup” correctly either by schedule or clicking the “Create restore point” button.

I’d checked the permissions on corona_gaming, and compared to a known good server successfully creating a restore point on a schedule, and manually:

When triggering a restore point from the UI, the logs show:

{“command”:“backup”,“uuid”:“1f10c1e0-a722-11ea-bc05-310735028b26”,“time_initiated”:1591357558014,“success”:false,“err”:1,“time_resolved”:1591357558072,“level”:“error”,“message”:"[corona_gaming] command “backup” errored out:",“timestamp”:“2020-06-05T11:45:58.072Z”}

The cron for “Archive with commit” is: 0 5 5 * * * (every day, 5.05)
The cron for “Backup” is: 0 5 * * * * (every hour, xx.05)

Now, the archive problem:
I’ve verified on all servers the archive works when triggered manually, but from cron, it doesn’t.
I just tried a cron on a known good server for 0 50 12 * * * (1 minute after the current time), started it, and tailed into mineos.log. No entry appeared in the log for the archive job.

It’s to the point where I’m now attempting to setup Multicraft and Pterodactyl, because backups, archives, and imports have never really been that reliable for me on MineOS, both on unRAID, and within a VM. If there’s anything else I can check, or any logs I can gather, let me know.

Ok, I’ve figured out part of this.

My issue with both operations failing on the “corona_gaming” server was resolved by creating a new server from a manually created archive. Everything working in line with other servers now.

The issue of cron archives failing with all servers has been partially solved: archive_with_commit" fails, “archive” does not. It’s something to do with flushing the server to disk first that causes it to fail, not creating the archive.

If there’s anything more specific I can provide, please let me know.

I’m having the same issue as described here. Archiving via a cron job fails, but manual archiving does not. The logs aren’t showing much – not sure if there’s anywhere else I can check?

mineos.log:

{"command":"archive_with_commit","source":"0 0 2 * * *","msg":"","enabled":true,"success":false,"err":true,"time_resolved":1621303210503,"level":"error","message":"[The_World] command \"archive_with_commit\" errored out:","timestamp":"2021-05-18T02:00:10.504Z"}

cron.config:

command=archive_with_commit
source=0 0 2 * * *
msg=
enabled=true

Nothing of note in the regular logs files within the logs directory of the server.

It looks like I can manually edit my cron.config to change the command to archive (as opposed to archive_with_commit) and it now archives correctly.