Archive, Backup, and World Files not up to date


I’m trying to migrate my world currently loaded in MineOS Turnkey into MineOS running in a docker container. The problem is the backup, archive, and even the world files in MineOS Turnkey are not up to date. Instead, it’s pulling the state of the world from about a month ago when I originally imported it into MineOS Turnkey. But, when I get into the MineOS Turnkey world I see everything I did over the course of that month.

What is the best way to export an updated version of the world? It appears the /save-all command doesn’t work. I’ve run it both manually in the world and I have MineOS configured to save-all every 5 minutes. And, I have read other forum posts where this has been an issue but they don’t seem to supply a solution.

Click the backup/archive buttons in the webui and wait a couple of minutes.

Yes, I have done this. I’ve clicked both buttons and waiting for the green popup that the archive and/or backup are complete. But, both of those create a backup/archive of an out of date version of the map.

You mustn’t be looking at the correct file/s then.

I should be pulling the right archive. Just to be sure I’ve been deleting all previous archives and backups and creating them again which doesn’t seem to be working either.

Do you do this while the world is running?
Do a “save-all” first to force any map changes to disk. This must be done in-game (or in the input line in the bottom of the log-window)

I’ve run the /save-all command as well both in game and set it to automatically run every 5 minuets from the mineOS WebUI


Here’s an update:

After navigating through the files in the archive I have discovered that there are two worlds saved in the directory. One is in a called “CrossServ” and is the Minecraft server as it was before I imported it into MineOS Turnkey. The other is labeled “world” and it includes the current state of the world.

Now the problem is getting MineOS running in the docker container to pull the correct world. So far I have tried deleting the out of date world called “CrossServ” and relabeled the world called “world” to “CrossServ” This resulted in MineOS generating a whole new world. Then, I tried reversing the names of the world which again resulted in MineOS generating a whole new world.

Finally, I tried just zipping the folder called “world” and importing that and it finally resulted in the correct world being generating.

Your has a property called level-name (if I remember correctly), that is where the world name is set, by default it’s world. This is where we didn’t understand, that the world was called something different/ you had more than one world in the folder. You could have renamed the folder and achieved the desired result.