1.20.1 Forge server will only start without mods

Hi everyone, so I’m pretty new to virtualizations/containers as a whole and I’ve been doing my best to get everything going on my own but Ive hit quite the roadblock
Specs List:
Dell NX3230 running TrueNAS Scale
MineOS running from pre-configured app within truenas web interface - docker container
Intel Xeon e5-2630 x1 (planning to add a second cpu in later but i doubt thats relevant)
32 gigs of DDR4 ECC (planning to add another 32 with second cpu)

I managed to get a 1.20.1 forge ver 47.2.0 server online and working with 0 mods, it was a bit of hell to get there as I had to follow tons of forum posts and google searches to end up at Minecraft forge 1.18.1 no targetable jar
Followed these instructions and put @user_jvm_args.txt @libraries/net/minecraftforge/forge/1.20.1-47.2.0/unix_args.txt into my add java arguments thru MineOS web interface. This gets the server online and functional with no mods in the folder and appears as though everything is working (I didnt actually install a 1.20.1 version of forge with no mods but thru clientside mc launcher with mods server responds and gives me an error to remove mods that arent server side upon joining so I would assume its working)

As soon as I attempt to add the mods into the folder, I no longer am able to start the server and log outputs are completely minimal. Im at a bit of a loss here and can’t seem to find any relevant info on why this might be happening
I have tried adding in mods one by one and no matter the amount of mods or which mod it is, its the same result no matter what

link to modpack I want to use -
I downloaded the server side mod files and tried just copying mods and copying all files within, same result either way

Log outputs will be down here - retried from files as the log output thru MineOS web interface doesnt display anything when trying to start the server

[25Feb2024 17:05:20.689] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [–launchTarget, forgeserver, --fml.forgeVersion, 47.2.0, --fml.mcVersion, 1.20.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20230612.114412, -jar, forge-1.20.1-47.2.0-universal.jar, nogui]
[25Feb2024 17:05:20.693] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 10.0.9+10.0.9+main.dcd20f30 starting: java version 17.0.2 by Private Build; OS Linux arch amd64 version 6.1.63-production+truenas

[25Feb2024 17:05:20.689] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [–launchTarget, forgeserver, --fml.forgeVersion, 47.2.0, --fml.mcVersion, 1.20.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20230612.114412, -jar, forge-1.20.1-47.2.0-universal.jar, nogui]
[25Feb2024 17:05:20.693] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 10.0.9+10.0.9+main.dcd20f30 starting: java version 17.0.2 by Private Build; OS Linux arch amd64 version 6.1.63-production+truenas
[25Feb2024 17:05:20.717] [main/DEBUG] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Found launch services [fmlclientdev,forgeclient,minecraft,forgegametestserverdev,fmlserveruserdev,fmlclient,fmldatauserdev,forgeserverdev,forgeserveruserdev,forgeclientdev,forgeclientuserdev,forgeserver,forgedatadev,fmlserver,fmlclientuserdev,fmlserverdev,forgedatauserdev,testharness,forgegametestserveruserdev]
[25Feb2024 17:05:20.730] [main/DEBUG] [cpw.mods.modlauncher.NameMappingServiceHandler/MODLAUNCHER]: Found naming services : [srgtomcp]
[25Feb2024 17:05:20.742] [main/DEBUG] [cpw.mods.modlauncher.LaunchPluginHandler/MODLAUNCHER]: Found launch plugins: [mixin,eventbus,slf4jfixer,object_holder_definalize,runtime_enum_extender,capability_token_subclass,accesstransformer,runtimedistcleaner]
[25Feb2024 17:05:20.754] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Discovering transformation services
[25Feb2024 17:05:20.758] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path GAMEDIR is /var/games/minecraft/servers/Create
[25Feb2024 17:05:20.758] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path MODSDIR is /var/games/minecraft/servers/Create/mods
[25Feb2024 17:05:20.759] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path CONFIGDIR is /var/games/minecraft/servers/Create/config
[25Feb2024 17:05:20.759] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path FMLCONFIG is /var/games/minecraft/servers/Create/config/fml.toml

I am more than sure there is a lot of information that will be needed that I didnt provide so please feel free to ask, any and all help would be greatly appreciated as I am definitely a noob when it comes to this stuff
Ive messed around with minecraft servers for years but it was always from within my own personal pc on windows, I just recently started to get into an actual networking setup. I know im not necessarily stupid, ive managed to get a few other servers online using fabric, paper and vanilla but forge is a bit of a different animal and I’ve gotten absolutely lost here, especially with no real log outputs to google

figured I’d add the logs from the working version of the forge server with NO MODS
[25Feb2024 17:35:09.136] ain/INFO] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Launching target ‘forgeserver’ with arguments [-jar, forge-1.20.1-47.2.0-universal.jar, nogui]
[25Feb2024 17:35:09.966] ain/INFO] [net.minecraft.util.profiling.jfr.JfrProfiler/]: Started flight recorder profiling id(1):name(server-1.20.1-2024-02-25-173509) - will dump to debug/server-2024-02-25-173509.jfr on exit or stop command
[25Feb2024 17:35:15.344] odloading-worker-0/INFO] [net.minecraftforge.common.ForgeMod/FORGEMOD]: Forge mod loading, version 47.2.0, for MC 1.20.1 with MCP 20230612.114412
[25Feb2024 17:35:15.346] odloading-worker-0/INFO] [net.minecraftforge.common.MinecraftForge/FORGE]: MinecraftForge v47.2.0 Initialized
[25Feb2024 17:35:15.864] [Forge Version Check/INFO] [net.minecraftforge.fml.VersionChecker/]: [forge] Starting version check at https://files.minecraftforge.net/net/minecraftforge/forge/promotions_slim.json
[25Feb2024 17:35:16.242] [Forge Version Check/INFO] [net.minecraftforge.fml.VersionChecker/]: [forge] Found status: UP_TO_DATE Current: 47.2.0 Target: null
[25Feb2024 17:35:17.047] ain/INFO] [com.mojang.authlib.yggdrasil.YggdrasilAuthenticationService/]: Environment: authHost=‘https://authserver.mojang.com’, accountsHost=‘https://api.mojang.com’, sessionHost=‘https://sessionserver.mojang.com’, servicesHost=‘https://api.minecraftservices.com’, name=‘PROD’
[25Feb2024 17:35:17.801] ain/WARN] [net.minecraft.server.packs.VanillaPackResourcesBuilder/]: Assets URL ‘union:/var/games/minecraft/servers/Create/libraries/net/minecraft/server/1.20.1-20230612.114412/server-1.20.1-20230612.114412-srg.jar%23101!/assets/.mcassetsroot’ uses unexpected schema
[25Feb2024 17:35:17.801] ain/WARN] [net.minecraft.server.packs.VanillaPackResourcesBuilder/]: Assets URL ‘union:/var/games/minecraft/servers/Create/libraries/net/minecraft/server/1.20.1-20230612.114412/server-1.20.1-20230612.114412-srg.jar%23101!/data/.mcassetsroot’ uses unexpected schema
[25Feb2024 17:35:19.535] ain/INFO] [net.minecraft.world.item.crafting.RecipeManager/]: Loaded 7 recipes
[25Feb2024 17:35:19.662] ain/INFO] [net.minecraft.advancements.AdvancementList/]: Loaded 1271 advancements
[25Feb2024 17:35:20.301] [Server thread/INFO] [net.minecraft.server.dedicated.DedicatedServer/]: Starting minecraft server version 1.20.1
[25Feb2024 17:35:20.301] [Server thread/INFO] [net.minecraft.server.dedicated.DedicatedServer/]: Loading properties
[25Feb2024 17:35:20.302] [Server thread/INFO] [net.minecraft.server.dedicated.DedicatedServer/]: Default game type: SURVIVAL
[25Feb2024 17:35:20.302] [Server thread/INFO] [net.minecraft.server.MinecraftServer/]: Generating keypair
[25Feb2024 17:35:20.481] [Server thread/INFO] [net.minecraft.server.dedicated.DedicatedServer/]: Starting Minecraft server on
[25Feb2024 17:35:20.506] [Server thread/INFO] [net.minecraft.server.network.ServerConnectionListener/]: Using epoll channel type
[25Feb2024 17:35:20.651] [Server thread/INFO] [net.minecraft.server.dedicated.DedicatedServer/]: Preparing level “create”
[25Feb2024 17:35:22.970] [Server thread/INFO] [net.minecraft.server.MinecraftServer/]: Preparing start region for dimension minecraft:overworld
[25Feb2024 17:35:25.010] [Worker-Main-4/INFO] [net.minecraft.server.level.progress.LoggerChunkProgressListener/]: Preparing spawn area: 0%
[25Feb2024 17:35:25.024] [Worker-Main-4/INFO] [net.minecraft.server.level.progress.LoggerChunkProgressListener/]: Preparing spawn area: 0%
[25Feb2024 17:35:25.035] [Worker-Main-5/INFO] [net.minecraft.server.level.progress.LoggerChunkProgressListener/]: Preparing spawn area: 0%
[25Feb2024 17:35:25.043] [Worker-Main-5/INFO] [net.minecraft.server.level.progress.LoggerChunkProgressListener/]: Preparing spawn area: 0%
[25Feb2024 17:35:25.054] [Worker-Main-5/INFO] [net.minecraft.server.level.progress.LoggerChunkProgressListener/]: Preparing spawn area: 0%
[25Feb2024 17:35:25.472] [Worker-Main-1/INFO] [net.minecraft.server.level.progress.LoggerChunkProgressListener/]: Preparing spawn area: 0%
[25Feb2024 17:35:25.972] [Worker-Main-5/INFO] [net.minecraft.server.level.progress.LoggerChunkProgressListener/]: Preparing spawn area: 25%
[25Feb2024 17:35:26.472] [Worker-Main-5/INFO] [net.minecraft.server.level.progress.LoggerChunkProgressListener/]: Preparing spawn area: 83%
[25Feb2024 17:35:26.698] [Server thread/INFO] [net.minecraft.server.level.progress.LoggerChunkProgressListener/]: Time elapsed: 3727 ms
[25Feb2024 17:35:26.699] [Server thread/INFO] [net.minecraft.server.dedicated.DedicatedServer/]: Done (6.086s)! For help, type “help”
[25Feb2024 17:35:26.700] [Server thread/INFO] [net.minecraft.server.dedicated.DedicatedServer/]: Starting GS4 status listener
[25Feb2024 17:35:26.713] [Server thread/INFO] [net.minecraft.server.rcon.thread.GenericThread/]: Thread Query Listener started
[25Feb2024 17:35:26.713] [Query Listener #1/INFO] [net.minecraft.server.rcon.thread.QueryThreadGs4/]: Query running on
[25Feb2024 17:35:26.729] [Server thread/INFO] [net.minecraftforge.server.permission.PermissionAPI/]: Successfully initialized permission handler forge:default_handler

not particularly sure why but upon refreshing of my browser at some point it no longer lets me select the universal jar through the web interface of MineOS so I cant even start the forge server without mods anymore, so incredibly frustrated and ready to bang my head on my desk

Got it working update
I have absolutely no clue as to why this worked or why it took me so long to try it but I downloaded the vanilla 1.12.1 profile thru MineOS and launched with the 1.20.1 vanilla profile using forge universal jar with the same java arguments and first log output was an error along the lines of angry cause you didnt use correct launcher and then delved into server launch, server is online and I am playing.