1.18.2 forge server can't authenticate players

Whenever I try to join my server I’m unable to log in becauseit can’t reach Mojang’s authentication servers. Everything works fine if I set online-mode to false but enough people will be playing on the server that it shouldn’t be a permanent solution.

I think it’s something to do with the firewall. When all the mods try to check for updates, the log is filled with “java.net.ConnectException: No route to host” showing that more things are affected than just login.

Everything I’ve googled to try to fix the issue so far has been clickbaity and less-than-helpful. Throwing a blanket “allow all connections originating from this server” rule at iptables had no effect.

1 Like

Have you tried to download anything from that machine? If you set manual IP details try and use dhcp and try again.

You need to have all the following set:

  1. IP adress
  2. Subnet
  3. DNS server
  4. Gateway

Please check your network config on the server
You do not say what version of MineOS you have installed as the command for checking network config may differ. I make usre all my linux based servers have the command “ifconfig” available to check network connectivity

Turns out it’s an issue with forge??? If I use a completely vanilla server it’s fine but the moment I switch to forge, even without any mods, it stops working???

I switched to lubuntu 22.04.1 so it doesn’t seem like a mineos issue anymore…

I can confirm I’m also running into this issue, I run multiple servers on the OS, yet running forge 1.18.x or above for mods runs the issue of authentication.

Vanilla works without issue, Older modpack versions work. But i cant for the life of me get newer forge versions working.

Checking the server status via mcstatus comes up green for everything important. Ive checked everywhere but i think this is a mineos issue.
Other players can join my servers, just not the newer mod versions.

I run a forge 1.18.2 server. It’s not MineOS.
Have you enabled whitelist and forgot to add people?
Try sharing your logs, clear your latest.log and mineos.log and try and run the server, once it’s finished it’s attempt shut it all down and post the logs here via pastebin or something.

Here is my issue
albeit similar to the op, I do have errors reaching Java.
I’m running it under a VM.
anything past forge 1.18.X seems to run into this issue. I am running Java 17 jdk

I am fairly new to learning Mine OS and using linux networking. I may be missing something obvious. I dont think its the firewall as the other forge servers work.

Have you confirmed the server has internet connection?
If you type into the cli -

Does it have a response or time out?

The server has access to the internet
(edit)using offline mode also seems to work, however i wish to convert a previous vanilla server into a modded one. Would rather the users didnt lose their items.
you can see that at the bottom of the pastebin there for outside connections. trying to join
it simply cannot authenticate users nor use the service for checking the mod versions

Are they on the same network or outside your network? It shows a local IP, though I can’t be sure if that is their IP or yours.
Please post the output of the ping command.

I asked the forge devs about this issue. Their only response was “check your firewall”.

The only thing that worked was switching to windows. Nothing else did anything.