1.12.2 forge won't start

I tried everything but I can’t start my server I have been trying for like a month now btw I also use java 8

If you can post the contents of /var/log/mineos.log that might help.

Also the permission details of the folders and files.
Can you run the server from the terminal?
java -jar /path/to/jar

Ok I will post the log but I don’t really know what you mean about permission details

File and folder permissions the folders for the servers
Usually /var/games/minecraft/servers/

if you use winscp or filezilla you can see the perms on files easily

otherwise you have to do it in command line which is harder.

R W X means Read, Write and Run permissions basically and can be a barrier if you don’t have the perms set properly depending on what you are trying to achieve.

I think this server was down for a while

Whenever I try to post a copy of my log this site crashes

log out and back in it was happening to me too. Then refusing connection for 10-15 minuets each time.

Could try pastebin a paste link here

Ok i will give it a try

Ok yesterday i tried pastebin too but the log is too big for that even but I checked the perms and some are root and some are not what do I have to do there exactly

i had so many problems so I decided ti do fresh install but this time instead of using ubuntu i used Turnkey bullseye and I wanna know if it has ftp already setup or do i have to do it

Did you download the ISO from here or did you download from turnkey linux site?

If you use Winscp you can use SFTP on the ssh port.

I downloaded it from the turnkey site and I think I have to enable sftp that what it says. can you guide me one how to please?

No. I won’t.
Just download the version that hexparrot has put together. It already has mineos and firewall stuff done.

Ok nvm I figured it out. Now I am going to download java 8 and try to load it