Web UI won't load

I’m running MineOS on Freenas and everything was working fine for months and then a few days ago the Web UI wont load. The jail loads fine as when I go the the shell the default MineOS screen loads up. Is there anything specific I should be looking for to fix this? I’ve tried restarting the jail and server and nothing changes.

I’ve tried searching but I haven’t been able to find anything that resolves the issue.

Can you elaborate on your issue a bit more?

  1. What error message(s) are you getting?
  2. Where there any changes since this last worked?
  3. Have attempted any troubleshooting steps, and so, what were they?

I get an ERR_CONNECTION_REFUSED error when trying to hit the Web UI URL. No changes as I haven’t updated anything recently. As far as troubleshooting, all I have done is restart the jail and server and nothing changes. The jail does appear to load properly so I do have access to the cmd in the jail.

Can you check this page for a few tests on whether the webui is running: Megathread for MineOS webui issues - #3 by hexparrot

Basically, enter the jail, and identify:

a) is there a nodejs process running? (ps)
b) is it listening on the port? (netstat -ntlp)
c) are you definitely using https in the URL?

Looks like the webui is not running. Is there a specific command I should run to start the process?

This is what I get when trying to restart the service:

I just ended up resolving the issue by installing mineos in a new jail and copying the servers over.