Web UI not running server created as 'root' properly

hi Cyphecx,

you have some work to do to salvage your FTB servers. (multiple?)

i can see from your posted log that the server is starting normally but because you still use the old saved world files things are not loading/working properly. my feeling is it has to do with the original issue Sir hexparrot solved for you namely, using root.

again, my own feeling but by using root a whole cascading unforseen series of events take place and unintended results occur. every time. take it from me, Hahaha, i know all about it so welcome to the club.

no worries, now we know. MineOS used as intended works great. it even works great used as unintended. it was never intended to be used as root so the headline “Web UI not running server properly” is missleading. trash in trash out at best is the rule.

anyway, what i mean is this: for whatever reason your old “world” file was built with mods like tinkers constuct. open computers, storage drawers and the like. but now, as the server loads the world those mods are not loading properly. as such the server deals with items made with the mods by posting warnings and dealing with them as it can by skipping them or whatever.

finally it looks like it errors out and crashes but i’m not sure. whatever.

it seems to me the original error of building the servers as root has had its residual effects here.

now you will learn what the back ups and archives are for, lol.

make them, move them. delete your servers. rebuild your servers as intended (mc as user, not root) import your back ups and get them up and working properly. (i would use the node js version, just a thought.)

when all the mods load and are working the old world files should load and work fine as well.

help is around here someplace but it is a big sports weekend in the usa.

good luck!

tNt

EDIT: forgot to mention, you may have to end up rebuilding your servers and importing only the world folders because the saved archive as is may still crash. you simply get the new FTB servers up and stable with all the mods running, shut down, place your old world files into the new world folder and see what happens when you start the server.

Thanks so much for the reply! So what Im gathering is that I should just grab the world file that I want to use from the current server and recreate everything making sure not to use root inapropriately? As for using root, is there anything I should know besides that I should only use root to preform the chown command on my server directories? If so thats no problem, as I have only got the one server right now. As for the title being misleading what would you suggest I change it too? Thanks again my friend!

hi Cyphecx,

yes! you have it exactly. first recreate your server without using ‘root’. default user is “mc” as created by Sir hexparrot. of course you can change it to whatever you want, just not ‘root’, lol.

once it is up and running with all the mods you wanted working together and stable, it has already generated a ‘world’ and world folder.

all you do then is replace the files in the world folder with the files from the original server. (SFTP or whatever method you choose with the user name you decided to use, just not as root.)

it will work, up and running stable or it will not. if not, it will give you a log file to begin to help trouble shoot the issues. please let us know what happens.

the only other thing i found i need root for was to gain access and modify the iptables as outlined on this page:

https://minecraft.codeemo.com/mineoswiki/index.php?title=Iptables

i no longer do that as i have found i prefer one instance of minecraft per server, not multiple instances on one server. i use vmware and virtual servers for that purpose.

Good Luck!

tNt

EDIT: since you asked, lol. “Web UI not running server created as ‘root’ properly” or some such.

I find the easiest way to resolve this is by archiving and importing:

  1. log in as the initial server owner (in this case, root)
  2. create an archive of the server (while it’s down)
  3. move the file (or copy) to /var/games/minecraft/import/
  4. log in as the intended server owner (e.g., mc)
  5. Go to “Import a Server” and click “create server from archive”

The newly imported server will be owned by the non-root user, now.

  1. (optional, but probably desirable), remove the initial server from root in the webui.

So I tried first, to use the method hexparrot reccomended, but the first thing I noticed is when I logged into the UI using root, the account had no servers. I tried the same steps using the mc account and no dice. Next I tried to delete everything except the archive I made just in case using root and winSCP and remade the server using mc and the webUi and running FTBInstall.sh using mc and the same problems persisted. World gen was not being overridden and becoming a void world, and I didn’t have access to any non-vanilla server commands. This leads me to the original theory I had, that what ever series of scripts are being run when I click the start button in the UI is missing something that the ServerStart.sh provided by FTB has.

Well, you can open ServerStart.sh and see exactly what it does. Then, you can compare it to what MineOS does, which is very predictable…

java -jar somejar.jar -Xmx 1024 -Xms 1024 nogui

What does that mean that it just didn’t work. Did you get an error? Did you not see that the archive was created? What behaviors indicate to you that creating an archive through mc didn’t work?

What I meant by it didn’t work is that I was getting the same issues. Commands werent showing up and I assume that had I made a new world it would not have generated properly.
http://pastebin.com/9rJD9Q3S These are the contents of the ServerStart.sh. It seems to have quite a different set of commands than

java -jar somejar.jar -Xmx 1024 -Xms 1024 nogui

If there is a way to make the server run the ServerStart.sh rather than run the other command that would be the next thing I want to try.

You’re going to need to start providing at least a little detail as to what you expect vs what you’re getting. As is, you are being vague about all behaviors and are not answering the questions I am asking you.

Such as?|

No, this is not something that MineOS will do. Again, I’m trying to work with you to make MineOS run all the commands you find necessary to get the operation you want, but if you don’t express what you need MineOS to do, I (and everybody else here) cannot help you make MineOS do that.

As a side note, lots of people have gotten FTB servers to work, Skyfactory and others. At this point, I have no idea what jarfile you’re even having the webui set to run.

There is literally no information that can help me determine if this is a MineOS issue or user error.

hi Cyphecx,

a long, long time ago i did the “ServerStart.sh” thing. all it did was start and install the ftb jarfiles in their proper locations via FTBInstall.sh and set configure some settings.

my question now is why are you using it? MineOS creates and starts servers without it. MineOS also downloads imports and installs FTB servers without it.

i gather you can not get a server to start at all now or even create one. this is not common. used as configured, i have created and deleted many, many FTB servers with MineOS without problems.

i also gather you are doing everything by command line? if so, why? have a hard look at the MineOS WebGUI, everything required to set up vanilla and modified servers is there already.

to get a basic server created and world generated without mods is so simple it is no effort at all. have you achieved this yet? if not, i would start there.

after that use MineOS to download ind install the desired flavor of FTB using the utility provided in the MineOS WebGUI. tutorials are all over the shop here, a poke around might serve you well.

to help you, more information on what you are doing and how/why is certainly required as indicated by Sir hexparrot because doing things differently than we are accustomed to needs to be explained so the path to success can be navigated.

waiting to hear from you, best regards,

tNt

To clear up an confusion I may have caused let me go over my problem. First I could not get any of my FTB servers to start which I eventually figured out was because I needed to select the vanilla server jar from the WebUI and for that to show up I needed to run FTBInstall.sh or ServerStart.sh through the console. (while writing this comment and testing I found the right way to do this is probably to copy server files from both the whatever ftb profile and from its vanilla version counterpart and run from the vanilla jar and yes I did test that I was getting the same problems even if I did it this way)

Now, the problems that I started this thread for are that modded server commands such as the /xu_powersharing command from Extra Utilities 2 simply don’t exist when I try them or type /help. Also, the yu no make good map mod is supposed to override world gen and create a void world, which it does not do and generates normally, when the server is started with no world through the WebUI. Other things I have noticed are that the icon under the player count shows the server as vanilla when run through the WebUI(http://imgur.com/aYJB7Cx), but recognizes it as modded when run through console(http://imgur.com/9jsY6Kr) and that while the running through putty takes about a minute to start, but running through the WebUI takes seconds to start, while both tests had a world already generated. I should also mention that once a random assortment of modded items just deleted themselves from the world when I ran the server through the WebUI for testing, but this only happened once so I am not sure if it is related.

I may have missed other small things that are missing when run through the WebUI. In reality I could just keep running the server the through the console like I have been but this for me has been a learning experience and I would not feel right if I did not get it working as best as I could, so I would like to be able to run it through the UI rather than the commandline on my personal computer. Again Im a extremely new to linux, networking, and running a server in this way, so if I said anything that doesn’t make sense I apologize. Thanks for helping me anyway!

hi Cyphecx,

wow, alot to go through here. first understand i am not looking over your shoulder there and have to go by what you are writing here. so lets see if i can follow along.

this is all wrong for the following reasons (none having to do with your using root but no doubt was an issue), my best luck getting an FTB server running was to follow step by step (others use different steps but all lead the same place):

  1. all in WebUI, create the server and configure the server config. (i only change 4 settings) so now my chosen server name is in the drop down box.
  2. download the vanilla minecraft of desired version in profiles, left side of WebUI.
  3. select that vanilla mc in the profile box, set java parameters, (min and max mem). and chck the broadcast server box.
  4. start the vanilla server, accept the ULEA, restart the server. this generates a world. then click the ‘live profile’ button.

if you can’t get this far an FTB server in the WebUI is beyond you at this point.

once a vanilla server is up, running, stable and established, stop it and move on to creating the FTB server by:

  1. again, all in WebUI, select and download the desired FTB files in the profile section, (note that some links are not working sometimes but can be manually d/l via the FTB client launcher and manually imported, i think Skyblock might be one of those. slightly different steps taken to get it working in that case). i will power on my server later to confirm.
  2. select and run the FTB jarfile in the drop down box. start the server.
  3. EULA again,start again. server should load all mods, start and you can log on via the client and move on to SFTP u/l your ‘world’ folder and get that one working.

none of this is done from the command line but i suppose all of it can be done from a command line. you would not require a WebUI at all in that case and limits the value of having MineOS available.

i might have forgotten something but a quick review of the instructions would remind me.

where did you type this BTW? you will find a command line interface inside the WebUI, down at the bottom of the screen that looks alot like a command box sowing the server status. enter commands there. there is also a screen for making players OP. OP commands are entered in the clients terminal.

from your pictures i can see you are starting 2 different servers with the same name, one modded and one vanilla. this can be done in MineOS as well by selecting that profile in the WebUI. vanilla takes seconds and a modded server takes longer to load.[quote=“Cyphecx, post:23, topic:1726”]
In reality I could just keep running the server the through the console like I have been but this for me has been a learning experience and I would not feel right if I did not get it working as best as I could, so I would like to be able to run it through the UI rather than the commandline on my personal computer. Again Im a extremely new to linux, networking, and running a server in this way,
[/quote]
it sounds like you spent a lot of time and effort to learn about Linux and command line and stuff.

i guess you missed the part where the WebUI eliminates all that, lol. AFAIK it was created for that reason, to simplify the mc experience.

so where to go from here? if it was me, i would start over by deleting everything, re-install the MineOS.ISO, use the default mc as user, note the assigned IP, log in via the WebUI and go from there.

if you are required to use the command line for whatever reason my advice may be of little help to you.

very best regards,

tNt

EDIT: [quote=“tNt, post:24, topic:1726”]
(note that some links are not working sometimes but can be manually d/l via the FTB client launcher and manually imported, i think Skyblock might be one of those. slightly different steps taken to get it working in that case)
[/quote]
in this case, command line and ServerStart.sh/FTBInstall.sh are also not used and i can go through it if required and will build a server here with you to confirm. i have also u/l my working skyblock server archive for others in the past and can again if needed, if i make one.

EDIT 2: i decided to build 2ea servers to refresh myself of the flavors FTBPresentsSkyfactory25-2.5.6 and FTBPresentsSkyfactory3-3.0.6 from the WebUI only. after that i will build the very latest Skyfactory available (need to discover what it is first). What version are you trying?

For the first part about the vanilla jar I did mention I had found a much better way to do it.

As for the commands not working, they don’t work ingame or in the UI console. I did not test that particular command in the console as it is playerbased but /help always reveals 9 pages(vanilla amount) when run through the WebUI and 22 pages(FTB amount) when run through console. BTW those pictures are not 2 different servers. They are the exact same server just run through the WebUI or by running ServerStart.sh through the commandline.
Skyfactory 3.0.6 is what I have been working with for this post
If there are no other suggestions soon I will probably go with reinstalling mineOS and starting from there.

If your minecraft client reports a vanilla server when you start from the WebUI, then that is most likely what are being started. Which JAR-file are you chooing in the WebUI? If it is the proper FTB JAR pleas check the following:

in the server directory there is a file called server.config. This is MineOS’s server information that it users to start your minecraft server. If you open that file, what jar do it say that it will start?

You can also manually edit in the JAR you want it to start, please do that using the same file you use when you start the server in the console (just the jar file name). PLEASE NOTE: Doing it this way you will most likely not see a jar chosen in the WebUI, but press “start” anyways (without choosing JAR). Choosing, or pulling down the JAR menu) will in most cases reset “server.config” to whatever jar MineOS thought you where choosing (including no file if you do not choose…)

Selecting the FTB jar does not start at all it says its up for about five seconds, nothing happens then it shuts down thats why using the webUI I select the vanilla jar.

If you select the vanilla jar, it starts the vanilla server.

Again: What is the name of the jar you choose in the WebUI when you try to start the FTB server and do not choose the vanilla jar?

1 Like

If I didnt use the vanilla jar, for Skyfactory 3 this is the jar I used FTBserver-1.10.2-12.18.3.2215-universal.jar and It has never worked for me

well i got both servers running in about an hour and logged in to the 2.5 with my client.

i was not on a single block with a tree but all mods were there and working.

with the same client it would not load the 3.0.6 and errored out so without the client i could not log in to the server but from the logs/latest log page in the WebUI type /help returns 22 pages indicating all mods are loaded.

i’ll be AFK for a while. then troubleshoot my client

good luck!

tNt

Alright, for clarity, here are the steps I did just this moment, to get a skyfactory3 server up.

  1. Logged in as mc into the webui
  2. Downloaded the FTBPresentsSkyfactory3-3.0.6 profile
  3. Created a new server (e.g., called it “skyfactory”)
  4. Went to server status, selected “change profile to” => “FTBPresentsSkyfactory3-3.0.6”. Clicked “Copy Profile to live server files”
  5. Clicked “Accept EULA”, then “Accept EULA” in popup. Closed popup.
  6. Changed -XMX to 1024
  7. Logged into the command prompt as mc
  8. cd /var/games/minecraft/servers/skyfactory
  9. sh FTBInstall.sh
  10. Went back to webui, set “Change runnable jar to” => “FTBServer-1.10.2-12.18.3.2215-universal.jar”
  11. Hit Start.

From LOGGING:

[16:36:57] [Server thread/INFO]: Preparing level "world"
[16:37:00] [Server thread/INFO]: Preparing start region for level 0
[16:37:01] [Server thread/INFO]: Preparing spawn area: 21%
[16:37:02] [Server thread/INFO]: Preparing spawn area: 28%
[16:37:03] [Server thread/INFO]: Preparing spawn area: 73%
[16:37:04] [Server thread/INFO]: Preparing spawn area: 78%
[16:37:04] [Server thread/INFO]: Done (7.169s)! For help, type "help" or "?"
[16:37:09] [Server thread/INFO]: FTBLib: Server reloaded in 71ms
[16:37:12] [Server thread/WARN]: Can't keep up! Did the system time change, or is the server overloaded? Running 2557ms behind, skipping 51 tick(s)
[16:38:59] [Server thread/INFO]: --- Showing help page 22 of 22 (/help <page>) ---
[16:38:59] [Server thread/INFO]: warp
[16:38:59] [Server thread/INFO]: weather
[16:38:59] [Server thread/INFO]: whitelist
[16:38:59] [Server thread/INFO]: worldborder
[16:38:59] [Server thread/INFO]: xp

The FTBLib shows it’s loaded.

1 Like

Im doing a fresh install right now and will follow those steps and see what happens

After a fresh install and following hexparrot’s steps exactly except for adding more ram everything is working the way I want it to! I assume the problem is that I did something stupid while using root.Thank you everyone who has helped me!

1 Like