Systemctl start mineos not working

systemctl list-units --all --failed

Try this and see if anything stands out also run the java command make sure its installed also check its status and that it is running.

The guide at the top says

Installation steps

The following steps must be executed as root.

systemctl list-units --all --failed
command gave me this

● mineos.service loaded failed failed Start MineOS minecraft front-end

LOAD = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB = The low-level unit activation state, values depend on unit type.
1 loaded units listed.
To show all installed unit files use ‘systemctl list-unit-files’.

Do the rest of the previous post and make sure java is running,

MineOS is installed now so you don’t need to be in root now either. Although I cleared that statement from the other post because you are troubleshooting. You need to keep in mind that if you tamper with user 1000 files as root then you will cause perm issues and that will be your next problem, initially why i mentioned it but retracted it because you are troubleshooting something.

he’s trying to help me set one up for my own server bc i didnt need my old laptop anymore so im using it as a linux server

I did test to see if java is installed and it gave me this

java -version
openjdk version “11.0.21” 2023-10-17
OpenJDK Runtime Environment (build 11.0.21+9-post-Ubuntu-0ubuntu122.04)
OpenJDK 64-Bit Server VM (build 11.0.21+9-post-Ubuntu-0ubuntu122.04, mixed mode, sharing)

nvm i missed this part, exit code 0 so it mean it loaded java’s service. But i would still check to see if its running, use the same systemctl command you used to check mineos

Also might need to look at mineos log, hard to say because the service is not running so there might not be one but just look and see if there is any as its probably starting then stopping.

How would I I dont ever have many errors when Doing this stuff so I dont know how to check java or hard logs

1 cd var/log

2 nano mineos.log

or just ftp to var/log/mineos.log

to check java just do systemctl java or systemctl js.service

i also don’t have a server atm so i cannot check this guidance before i suggest it. but those should be correct commands.

to get back to home just cd by itself or cd ./ maybe i cannot recall atm.

sudo cd var/mineos.log
sudo: cd: command not found
sudo: “cd” is a shell built-in command, it cannot be run directly.
sudo: the -s option may be used to run a privileged shell.
sudo: the -D option may be used to run a command in a specific directory.

nano mineos.log was empty

sudo systemctl java
Unknown command verb java.

read what it is telling you, remove sudo from the command you are also logged in as root i am pretty sure so you don’t need to use sudo as root.

java unknown so it meas use the second systemctl command

cd var/mineos.log
bash: cd: var/mineos.log: No such file or directory

and still the same thing for the rest

It did the same thing there to

this means there is no log so forget that part now.

heed this what does it say?, you also need to be a bit more clearer with your response

When running that
Unknown command verb js.servic
is all I get And I dont know what to do about that

sorry its systemctl service js.service or systemctl service java

Sorry my fault

No it is not your fault it is doing the same thing again and I am unsure of why cuz I tried it on my own server and it worked with that and I have mineos running fine

ok it could be a node.js issue also so go back over the node section in the guide and redo the commands, only for the node part. Restart the computer after that and see if it changes.

the log output in your OP is saying that both mineos and nodejs are loaded but i would retry the commands for node and see what happens.

Ok then I will do that and be back

Ok I did it but the same stuff is happening

I am at a loss hard to diagnose something with limited information and not being in front of it.

MineOS Turnkey is an option that will work right out of the box. I recommend this because its setup well, personally i prefer this distro for this reason because its tailor designed for MineOS and just works.