Start button does nothing

I’ve just installed mineOS Turnkey and I’m having trouble getting my first server to start. I followed the YouTube video for creating a new server but when I press the start button nothing happens. I get no notifications or failures.

I checked mineos.log and it just reads {“level”:“info”,“message”:"[test] received request “start”",“timestamp”:“2018-11-08T15:06:30.902Z”}

I tried creating another new server both on root and MC, but with the same result.

I went into the server via SSH and true to start it manually with “java -jar minecraft_server.1.13.2.jar” and I got the following error.
Error: Invalid or corrupt jarfile minecraft_server.1.13.2.jar
Thinking it was just a bad download I deleted that jar in the server folder and the profile folder and redownloaded it. However, it still gives the same error and the start button still does nothing. I tried 1.13.1 as well with the same result on both the GUI and SSH.

I’ve checked eula.txt and it’s set to true, so that’s not it.

There are no server logs since the server has never started.

EDIT: I also tried updating the webui, it didn’t help.

IF you search the forum you will quickly discover that this is a bug, and that updating MineOS (yes even after a clean install from th ISO’s) fixes this.

I tried updating before I even posted this, it didn’t seem to help. I had forgotten to add that to the original post, it’s there now.

I updated via the guide here

Per JayMontana36’s comment I tried an earlier version and that’s working. Maybe my update failed? How do I make sure I’m running the latest version?

You can check what git commit you’re on in the webui by clicking on your login name (top-right corner) or by using this command line instruction: Megathread for MineOS webui issues - #6 by hexparrot

Keep in mind, you might have an updated webui, but haven’t restarted the service (or host) and thus the older webui is still present and running.

I ended up blowing the server away and reloading it and then updating before doing anything else. This seems to have resolved the issue.