[SOLUTION IN PROGRESS] Can't download forge profiles

So, after using a forge 1.12.2 profile for a while, I checked in on my dashboard and decided to create a new server for building a city. I notice that my 1.12.2 profile is gone. I check the profile download page, and the forge profiles are gone. What should I do?

1 Like

I am having a similar problem. I reloaded a backup of my server and now I can’t run it because the Forge 1.12.2 profile isn’t there. There are no options for forge in the profile dropdown and refresh profiles doesn’t work either.

There are no longer Forge profiles in the profiles list, the rest seem to be there, refreshed Profiles and still not there. They were available when I created the server a week or so ago.

1 Like

It is because Forge has chaged how their servers are made available. MineOS and the profile list generator tries to download forge from this list: https://files.minecraftforge.net/net/minecraftforge/forge/promotions.json

That page gives a 404 Not Found, which again means that MineOS can’t find any files to make profiles from, and drops forge.

The files are still available here: Downloads for Minecraft Forge for Minecraft 1.16.5

1 Like

So, what Forge has done is take all their links to the server files, and serve them from their Maven-repository through Adfoc.us. Since they probably have a quite high number of downloads this helps them get some monetary support for their job. Unfortunately this means that MineOS no longer has a clean and simple list of server files to parse and create server profiles for the different forge files any more.

I fear that getting a list of the files after Forge’s rework of their download page will be a huge amount of work. MineOS has a git-repository : GitHub - hexparrot/mineos-node: node.js implementation of mineos minecraft management. If anyone knows .JS coding and would like to try to create a parser take a look at the following file: mineos-node/profiles.js at master · hexparrot/mineos-node · GitHub

Other than that it is entirely up to @hexparrot if the rework needed is feasible and doable in the current version of MineOS.

1 Like

Thank you for the update. Looks like there is no apparent json-replacement for the autogenerated list of forge builds. I’ve made a new commit on a dev branch to allow immediate use of the most modern versions, while a better plan is enacted:

Just an idea but cant you use parts of the FF addon called Universal Bypass?

No, unfortunately.

What you link is a browser plugin, while MineOS uses serverside scripting for its WebUI.

I’ll preface this by saying that I have no idea about coding or the working of MineOS. That said, I have a similar problem where Forge downloads get blocked because of adFly. The solution is to remove the adFly part of the URL. Example, from “https://adfoc.us/serve/sitelinks/?id=271228&url=https://maven.minecraftforge.net/net/minecraftforge/forge/1.16.5-36.1.12/forge-1.16.5-36.1.12-installer.jar” I remove “https://adfoc.us/serve/sitelinks/?id=271228&url=”. Would something like that, work for MineOS?. NOT that I don’t want to support Forge, they have done an amazing job and it is THE reason why modded minecraft is such a big thing,

And on the same vein, what would be the workaround to use Forge?. I use mineOS on a docker container (hosted on unRaid if that’s relevant), should I point the Forge server installation to the vanilla installation path? for example “/mineos/games/servers/awesomecoolserver”. I did check this but it doesn’t seem to be relevant anymore, or I can’t see how to create custom profiles =(

You guys are amazing, that actually worked! - I’ll leave the steps here in case it helps anyone, at least for me it was not straight forward how to make it work:

  1. Download a vanilla mc profile
  2. Create a new server and use the minecraft-server.jar to start it
  3. stop the server and navigate to the profiles folder for the vanilla profile you downloaded, something like: “/mineos/games/profiles/1.16.5”
  4. wget / copy the forge installer into it
  5. Go back to the UI and create a new server
  6. Select the forge installer (the file you just downloaded / copied) as your executable and start the server
  7. wait for the server to stop, it will take a while
  8. You can now select forge as your executable and there will be a mods folder created
  9. have fun!

Fair enough, i linked it because its written in languages which can be used on server side too…

Got a new commit out that fixes this. It actually made the list a bit cleaner, since it is reduced now to “-latest” and “-recommended” versions only–of each point release from 1.6 → 1.16.

Normal webui update should be sufficient


I already have the forge jar in the profiles directory, it still doesn’t appear as an option from the Server Status screen

has it been fixed? i can’t download any forge profile from the web-ui (already done an update)

Any news? Just did a webui update, but logs states:

{"level":"error","message":"Unable to retrieve profile: forge. The definition for this profile may be improperly formed or is pointing to an invalid URI."," timestamp":"2022-01-15T17:19:45.021Z"}

Mine has loaded the list in the UI.
What git commit version of webui are you running?
You could try refreshing your list if it’s not showing up at all - also an option in the menu in the top right corner.