Saveall_latest_log failed true

We are new to MineOS and we are running it on a Hyper-V host. Right now nothing will save out of memory - so the if we attempt any kind of reboot of the VM all the game changes are lost to a distant point in time. When we run a save-all we get this error on the console: saveall_latest_log failed true. My hunch is the content in memory is never being successfully flushed to disk. If someone can help point us in the right direction that would be ideal! Thanks!

  1. What kind of server are you running?

If it’s not vanilla–but more specifically, it’s a fairly niche server, it may not support “save-all” in the console.

If it is vanilla/ or a fairly popular server software, try save-all manually in the latest.log console. That way, you can see specifically what it is reporting back to you directly.

I’m running an vanilla box with mojang 1.16.5. If I run save-all from the latest.log it states is was successful. But if I reboot the VM the MineOS will only show changes back three months. I get the impression the memory is not actually flushing back to disk.

Three months seems a really long time…like, you haven’t had to stop the server and when you did it went back three months?

Perhaps it’s a botched permissions issue: Megathread for MineOS webui issues - #9 by hexparrot

If any of these files are mistakenly owned by any other user, e.g., root, new saves cannot succeed.

We have been lucky and haven’t had a need to reboot the VM - the VM has weekly checkpoints (snapshots) - so we realized the save-all wasn’t committing the changes to disk - so we’ve been forced to revert to a checkpoint to recover the memory content. Changing permissions on those directories doesn’t appear to have had any effect (though I’m not sure it was an issue - it all appeared to be owned by MC).

Did running save-all yield any error output? Were all the world files somehow not being written, per, the timestamps, the content? It’s a peculiar issue for sure

If I run save-all or even save-all flush it appears to work from the console - but the content never makes it to disk. I’m still stuck with the last save-all that is three months old. The drive is not space restraint so it should have plenty of room to write. I’ve noticed that the in memory usage is now 1.3GB which I suspect is the slow build up of the uncommitted saves.

Player data is saving - just not world data - as an additional odd footnote. Also if I attempt to run save-all from UI I always get a failure error.

Here is how the error shows up in the mineos.log

{“command”:“saveall_latest_log”,“uuid”:“6534ec80-dc25-11eb-abd0-43ea20ff6735”,“time_initiated”:1625333873480,“success”:false,“err”:true,“time_resolved”:1625333883477,“level”:“error”,“message”:"[Errors_Dungeon] command “saveall_latest_log” errored out:",“timestamp”:“2021-07-03T17:38:03.478Z”}

Stopping a server via stop should always write to disk, as well. Even if the save-all isn’t working like it should, well, you’re going to have to roll the dice sometime, may as well be with a planned, graceful stop.