Moved my server and now I get "ERR_EMPTY_RESPONSE"

Hello, thank you for trying to help. I run Open Media Vault with docker and portainer to manage my containers and installed MineOS through hexparrot/mineos. I had my server and home and it was running fine, but now I moved to my college place, and when I install the service exactly the same way I did before I get the “ERR_EMPTY_RESPONSE” when I connect to (serverip):8443

Has I said before was running fine and I just repeated the process, Added the port 8443 on the container and the host, changed mc password, bind the path to my harddrive, changed the UID to 1(as root, but already tried with 1000 and my user UID) and the logs of the container doesn’t show anything special LOG

I have been thinking of some settings in my router that don’t let me connect to the service, but I have other services installed like Sonarr and Transmission and they connect fine.

If someone has any idea of what can be causing problems please help, keep in mind that this is exactly the same setup as when it worked only the network changed to I think the problem is in the router. Thank you for your time.

Try some of the troubleshooting steps on the megathread page: Megathread for MineOS webui issues

Most notably, it seems likely your server is running, and running properly. Based on your error message, though, one or more of the links to complete the connection are stunted.

The aforementioned megathread should allow you to run commands on the MineOS host itself, which can be used to confirm operation.

  1. check via terminal that the host itself is listening on the port (netstat)
  2. check via desktop (non mineos server) ping connectivity works
  3. check open media vault if 8443 is being NATted
1 Like

Hello, I’m trying to run some of the processes in the megatread but I don’t know how I can run commands as mineos since it’s in a docker container, I’ve been searching but can’t find anything.