Imported Server Won't Start - MineColonies

The issue I have been having is not being able to start a MineColonies server. The server files can be found here: { }. I have been able to get previous version working, Minecolonies Official 1.16.5 v 3.3. I believe it may be related somehow to how the servers start up. The server files provide a “start” batch file of some sort and I am not sure if MineOS uses these or just a jar in the imported servers main folder. Any help would be appreciated. I’m not sure what other information would be needed to troubleshoot, so please let me know what info I can provide.

Edit: The logs tab on the left side does not appear after clicking “start” and neither does the “server started” popup. I tried selecting profile and jar, profile but not jar, jar but no profile, and also neither profile or jar.

I didn’t see anything in the logs that seemed helpful. Logs seem to show that the start request for the server appears, but nothing else nor error messages.

I tried looking into editing the batch file, manually adding the jvm or java args through the webui, and moving the location of the forge jar to the main folder of the server, but none of that seemed to do anything

I believe I figured this out. It most likely appears to have been due to not having Java 17, and possibly about the java args / jar file that I put in the server status page.

The Java 17 fix I found here: Minecraft 1.18 + Java 1.17 - #7 by ulaar
Java Args / Jar File info I found in this post: Minecraft forge 1.18.1 no targetable jar

I’m not sure if I did everything correctly, as the server does not appear to be using as much ram as I would expect relative to how much I allocated, but at least it’s working now. If anyone has further questions on how I “fixed” this issues, feel free to respond.