FTP connection issue over Linux Lite LTS


#22

Here’s a screen dump of m,y putty screen

putty%20one

If you’re ok with it, ill just keep pasting the screen dumps for you


#23

Alright, just as I expected…that “Welcome to Linux Lite” is actually the issue. This is because the SCP protocol can’t have extra stuff echo’ed to it or else it breaks protocol and aborts.

Here’s the fix… as mc:

vi ~/.bashrc

Now, remove all lines at the bottom of the file that start with “echo” (or comment them out by putting a # in front of it).

#echo -e "Welcome to $LLVER ${USER}"
#echo " "
#date "+%A %d %B %Y, %T"
#free -m | awk 'NR==2{printf "Memory Usage: %s/%sMB (%.2f%%)\n", $3,$2,$3*100/$2 }'
#df -h | awk '$NF=="/"{printf "Disk Usage: %d/%dGB (%s)\n", $3,$2,$5}'
#echo "Support - https://www.linuxliteos.com/forums/ (Right click, Open Link)"
#echo " "

Seriously, what a weird issue…


#24

Removed the lines, but how do I save and exit?
putty2
Closed putty and tried again. end up with this screen after you command.
putty3

press enter and it opens up the text in the top image again with the lines containing “Echo” as though I hadnt edited it.

Remove the lines again, but I cant save or escape putty to make the changes.


#25

Use nano ~/.bashrc if needed. Or otherwise, google how vi or other text editors can be used.


#26

Hexparrot…YOU ROCK!

I used the nano editor as I knew how that one worked. Commented out the lines and Went to test filezilla. Boom! up it came. Download and upload works fine.

So, as I cry tears of joy now that I have my server back to where is was before my entire upgrade saga began, Ill once again say thank you so much. Ill be making some notes on both of these forums for any future upgrades.

Keep up the awesome work,

Jeddell


#27

You’re very welcome, and I’m thrilled to hear it all is up and working for you.

It has been a learning experience for me, as well, as I was just downright-baffled by the echo causing an entire protocol to fail–I couldn’t have ever imagined!

Learning Linux is a journey, and as I approach almost nine years of having created MineOS and supporting it, you can bet it has stayed every bit of exciting and rewarding as you’d hope. (now my job is 100% linux!)