Creating new server from archive

I have created a new server from archive for testing purposes and I had trouble the first few times in selecting a runnable jar. after about 5 or 6 starts it stopped giving me a hard time. I had to make a second test server since I messed up on first one it will not let me start cause I can not choose a runnable jar, it drop box there is either not jars to select or when I select it goes in box for half a second and then goes back to “change runnable jar to:” after a few attempts the list is blank but files are still in server folder. When I copy spigot files back on server usign copy to server button, I can see jars in list again. I have tried to select a jar about 30 times it will not let me start my server. I have checked if webui needed an update it did something and no errors, still will not let me select runnable jar

  1. Have you tried restarting the host? (or the webui, more specifically)
  2. What commit are you on?
  3. Are there any errors in /var/log/mineos.log?

No I did not restart webui, not sure what you mean by commit? I don’t see errors but here is the logs with some of the start attempts I did get it to run but took me about 50 start attempts

    {"command":"create_from_archive","new_server_name":"shop","filename":"server-AaronsWorld_2016-06-24_08:07:26.tgz","awd_dir":"AaronsWorld","level":"info","message":"[WEBUI] Received emit command from","timestamp":"2016-11-19T21:48:57.028Z"}

{“level”:“info”,“message”:"[shop] Discovered server",“timestamp”:“2016-11-19T21:48:57.036Z”}
{“level”:“error”,“message”:"[shop] Create tail on logs/latest.log failed",“timestamp”:“2016-11-19T21:48:57.036Z”}
{“level”:“info”,“message”:"[shop] Watching for file generation: logs/latest.log",“timestamp”:“2016-11-19T21:48:57.036Z”}
{“level”:“error”,“message”:"[shop] Create tail on server.log failed",“timestamp”:“2016-11-19T21:48:57.037Z”}
{“level”:“info”,“message”:"[shop] Watching for file generation: server.log",“timestamp”:“2016-11-19T21:48:57.037Z”}
{“level”:“error”,“message”:"[shop] Create tail on proxy.log.0 failed",“timestamp”:“2016-11-19T21:48:57.037Z”}
{“level”:“info”,“message”:"[shop] Watching for file generation: proxy.log.0",“timestamp”:“2016-11-19T21:48:57.037Z”}
{“level”:“info”,“message”:"[shop] mc ( joined server namespace",“timestamp”:“2016-11-19T21:48:57.196Z”}
{“level”:“info”,“message”:"[shop] latest.log created! Watchfile logs/latest.log closed",“timestamp”:“2016-11-19T21:48:58.219Z”}
{“level”:“info”,“message”:"[shop] Created tail on logs/latest.log",“timestamp”:“2016-11-19T21:48:58.220Z”}
{“level”:“info”,“message”:"[shop] Server created in filesystem.",“timestamp”:“2016-11-19T21:49:54.812Z”}
{“level”:“info”,“message”:"[shop] eula.txt detected: ACCEPTED (eula=true)",“timestamp”:“2016-11-19T21:49:55.269Z”}
{“level”:“info”,“message”:"[shop] transmittting existing file contents: logs/latest.log (24734 bytes)",“timestamp”:“2016-11-19T21:49:56.014Z”}
{“level”:“info”,“message”:"[shop] issued command : “modify_sp”",“timestamp”:“2016-11-19T21:52:22.385Z”}
{“level”:“info”,“message”:"[shop] received request “modify_sp”",“timestamp”:“2016-11-19T21:52:22.386Z”}

There’s not enough log to know what the issue is. Most of the time, when you run into issues, the best first step is to update the webui (fixes discovered bugs) and in those steps it restarts the webui.

The ‘commit’ is the version of the webui.

Likewise, you can find this out in the top-right corner of the webui when you’re logged in. Commits refer to specific changes in code I make: Commits · hexparrot/mineos-node · GitHub . If you haven’t recently (or ever), I recommend you update the webui:

Updating the webui.

the git line reads;

git commit: 37e4a9d

So that tells me you’re using the webui in the state it was as of August 19, 2016.

And the other things, #1 and #3 (more logging than you provided, please)?

Had to reboot server webui would not update when I restarted it. Now it’s on git commit: d9a604b hope this fixes the issues